WordPress.org

Ready to get started?Download WordPress

Forums

Problem Accessing WP Externally Using WAMP (5 posts)

  1. BobRoberts123
    Member
    Posted 2 years ago #

    I set up our WP site to work locally under Wamp that installs Apache 2.2.21. The network administrator put the server outside the firewall (this is a Windows 2008 R2 server), so that the site can be accessed externally. In doing so, the IP changed, and I modified the WordPress database and various html/php files to reflect the new IP number. Keep in mind that the actual production site is functioning and hosted by a hosting company with the domain name associated with the site. Right now all I want to do is to be able to access the site externally with the IP number.

    Also keep in mind that if I type in (example number): http://192.168.9.999/nameofsite into a browser on the server that contains the site, the site runs ok, and I can access the WordPress administration page from that server.

    When I type in in http://192.168.9.999/nameofsite into an external browser, it gives, "Web Page Not Available". I check the Apache access log, and there are no entries. I cannot ping the 192.168.9.999 externally.

    Keep in mind the site physically resides in d:\wamp\www\nameofsite.

    I did go into d:/wamp/bin/apache/apache2.2.21/conf/httpd.conf and change the "ServerName localhost:80" to "ServerName 192.168.9.999:80". I restarted Wamp, but that didn't change anything.

    So my question is, are there clear, detailed, specific and explicit instructions for getting your WordPress site to be accessed externally using Apache once it works as a localhost?

  2. fonglh
    Member
    Posted 2 years ago #

    Is that the real IP you're using? 192.168 IPs are not publicly accessible. They have been designated as private IP addresses.

    Also, .999 is not a valid number in an IP address.

  3. BobRoberts123
    Member
    Posted 2 years ago #

    Good question. Yes, the IP that the network administrator said was made public does start with 192.168, but the 9.999 is fictitious and stands for the real number. I noticed that a prior address that he had made public and worked (though this was with IIS) started with 209.184. That address did strike me as fishy - so, I I'll go back to him and find out what the deal is.

    I do have an addendum to my question. Once I do get a good external IP, should I make these additional changes to the conf\httpd.conf file to accomplish what I want (get the IP accessed externally)?:

    Listen 192.168.9.999:80

    <VirtualHost 192.168.9.999>
    ServerAdmin someone@nonesuch.org
    DocumentRoot /www/nameofsite
    ServerName server-name
    ErrorLog logs/nameofsite-error_log
    TransferLog logs/nameofsite.com-access_log
    </VirtualHost>

  4. fonglh
    Member
    Posted 2 years ago #

    You should check with your administrator about server configuration.

    However, you will have to change WordPress' URL setting to the address you're using for it to work properly.

    See http://codex.wordpress.org/Changing_The_Site_URL

  5. BobRoberts123
    Member
    Posted 2 years ago #

    I don't know what you mean by "address you're using" - do I change it to the internal address (192.168...), the external address that is being translated to the 192.168 address (209.184...), or to the domain name - http://www.thenameofthesite.com?

    I've already changed it to the internal adddress and it doesn't work. I constructed a detailed post reporting what is going on, but no one will respond to it. The document you link to above is too vague to help me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags