WordPress.org

Ready to get started?Download WordPress

Forums

Problem 2.5.1 post_new.php and post.php (68 posts)

  1. mordormx
    Member
    Posted 6 years ago #

    Hey guys i just made the upgrade process and i found that to create a new post using Firefox is very very slow, after access to post_new.php the web browser is soooo slow to scroll on the page. The same for edit a previous post.
    I tried on Safari too, and there appear to have and endless loading elements, in the status bar appear "loading 25 elements from 250" "loading 35 from 450" and it continue doing the same, the elements number just grow and grow and grow, if i tried to access to publish a picture it just never load.
    Anyone out there have seen this behavior?
    I disabled all the plugins just to check if theres a conflict, but even without plugins the problem still there.

  2. mroulston
    Member
    Posted 6 years ago #

    I've having the exact same problem with 2.5.1 in Safari. I created my own thread about it earlier but still haven't gotten a resolution.

    As a test, I installed a fresh version of 2.5.1 on my server and it does not exhibit this problem in Safari. If worse comes to worse, I will try to export my blog from the upgraded installation to a new installation and see if that fixes the problem, but I'd rather not have to go through all that trouble, so I'm hoping someone might suggest an easier fix.

  3. BobGneu
    Member
    Posted 6 years ago #

    I too am having some performance issues with the latest update. All AJAX activities are lagged, tremendously. I let it run at one point to load the media embedding forms and i lost the ability to interact with firefox, at any level - it froze, not even the loading bar changed - for nearly 12 minutes. I updated yesterday evening and that is when all of this occured.

    I will be down grading to the flat 2.5 version of the app until some sort of fix is found.

  4. BobGneu
    Member
    Posted 6 years ago #

    The problem I am having is JS related. The save and publish buttons are flashing ( i think this is only a symptom however ) and the pages involved ( post-new.php and post.php in particular ) are having issues with the progressive save deal. It appears to be that they cannot save anything, but i really dont know if thats the issue.

    Continuing debugging.

    ffox 3b5 is much nicer in regards to letting you work between tabs in spite of the JS impact that WP is experiencing currently.

  5. BobGneu
    Member
    Posted 6 years ago #

    I am trying to disable autosave as that appears to be the issue here. The rest of the app is fine. I will return momentarily.

  6. Sam_a
    Member
    Posted 6 years ago #

    I had this problem too -- the browser is sending POSTs to wp-admin/admin-ajax.php over and over.

    It stopped after I cleared the browser cache and (in Safari) removed all my WordPress cookies, then relaunched.

  7. BobGneu
    Member
    Posted 6 years ago #

    Well mine is still posting them. I have tried changing the doAutoSave value to false and apparently thats not even being executed. I have commented out the entire file (autosave.js) with the same results.

    I have cleared all of my private data, cache and cookies included.

    Any further suggestions?

  8. mroulston
    Member
    Posted 6 years ago #

    What puzzles me is I installed a fresh version of 2.5.1 on my server and it doesn't do this problem with Safari. So as far as I can tell, this is not a blanket problem with 2.5.1 and Safari, but rather something going wonky during the upgrade progress.

  9. BobGneu
    Member
    Posted 6 years ago #

    I am leaning towards your position, noting that it occurs on opera, ie7, ie6 as well as the latest two versions of ffox. I am a little miffed about how the js files are not being used, even though they are included in the jquery format. I must have stayed out of the js lime light or something, but from what ive been able to tell there is something going on here that does not meet the eye.

  10. BobGneu
    Member
    Posted 6 years ago #

    The only thing i have been able to do is just disable js entirely. I have no idea what is going on but my file changes are not propagating (screams caching but i have even gone as far as to uninstall ffox and reinstall the bastard and cleared the cache countless times), maybe Comcast is just being a tribe of douches today.

  11. BobGneu
    Member
    Posted 6 years ago #

    If i block JS from my site i still have this issue come up. This is quite odd, i dont see any JS includes from other sites.

  12. ZeusII
    Member
    Posted 6 years ago #

    I got the problem of save/publish buttons flashing, wich If I made a fresh install didn't happen.

    Solved this way:

    - delete everything on your ftp related to wordpress (including plugins, theme and htaccess file
    - DO NOT DO ANYTHING TO THE DATABASE
    - upload a fresh 2.5.1 package to your server
    - modify wp-config.php
    - enter admin, enable default theme, check if everything is OK, verify the public view of the site
    - then, one by one, upload, enable and configure your plugins, checking the site and publish functions everytime
    - finally enable your theme

    I really don't what created this flashing buttons problem but doing this Is the only way I could sove it :/

    At this moment my site is 100% normal

  13. mroulston
    Member
    Posted 6 years ago #

    Thank you, thank you, thank you ZeusII. I followed your instructions and all seems to be working normal now.

    I spend the better part of the afternoon today trying fruitlessly to fix this, so I REALLY appreciate the detailed instructions!

  14. minute44
    Member
    Posted 6 years ago #

    I gotta say guys, I'm not experiencing this. Post_new loads within 5 seconds and edit post is even less.

    I just did a straight upgrade, none of this messing about removing all the files and re-activating plugins... it just worked.

  15. cuzoogle
    Member
    Posted 6 years ago #

    I am having this problem as well.

    script error when clicking on WRITE. Hangs and finally you have to stop the script to use the post box.

    Then if you try to publish it, something locks up my php, everything hangs and then I hit 25 processes running on my server which cuts me off and my site is down.

    Then I have to get the Host Gator Support to kill my php and myslq to get the site back up.

    a friend and I have tested it WITH NO PLUGINS, ON ANOTHER HOST and still get the script errors.

    When substituting a different DB the error went away so it is something in my blog DB for http://cuzoogle.com.

    any ideas? anyone else having this problem?

    WP support forums are pretty hard to find anything.

    we are starting to think the blog got hacked.

    Minute44, how does that help anyone?

  16. bmedia
    Member
    Posted 6 years ago #

    I'm having the flashing "save" and "publish" buttons problem too. Using FF (latest).

    I'm not sure I'm computer-savvy enough to really understand the instructions Zeus left above, though. Is Zeus basically saying, "start over with a fresh install of 2.5.1"? (In other words, can I just follow the upgrade instructions WP provides again?)

    Thanks anyone, in advance, for help!

  17. simpgr
    Member
    Posted 6 years ago #

    i having the same flash problem... it's real pain..
    hopefully so one will be able to help out.

  18. bmedia
    Member
    Posted 6 years ago #

    simpgr, I keep checking back here for the answer . . . we need a code genius and we need one now.

  19. Sam_a
    Member
    Posted 6 years ago #

    You can try deleting the wp-admin and wp-includes folders and repeat the 2.5.1 upgrade. Clear your browser cache, delete cookies, relaunch and hope. :)

  20. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    You can try deleting the wp-admin and wp-includes folders and repeat the 2.5.1 upgrade.

    Yes, this is very, very important and I cannot stress this enough. 90% or more of the problems I've solved via email were fixed by this simple trick.

    DELETE wp-admin and wp-includes from your server.
    UPLOAD those two folders again.
    DO NOT OVERWRITE FILES.

    I don't understand why some people cannot overwrite files properly (overwriting works fine for me every time), but everybody else seems to have this issue. If you try to simply overwrite the old WordPress with the new one, and something is wrong, then that is your problem; you cannot overwrite properly. Replace the files instead, by deleting first.

  21. cuzoogle
    Member
    Posted 6 years ago #

    thanks Otto you make us all want to continue using WordPress.

  22. BobGneu
    Member
    Posted 6 years ago #

    A clean install worked. I attempted to only replace the wp-admin and includes directories to no avail. The app still acted up. I dont know what the deal was, but i eventually created a dev location and set that up to test then moved to the production location. Pretty weird, i've never experienced this before, esp. not with WP.

    At least i can use it now. Thanks for your help guys.

  23. GMB
    Member
    Posted 6 years ago #

    - delete everything on your ftp related to wordpress (including plugins, theme and htaccess file
    - DO NOT DO ANYTHING TO THE DATABASE
    - upload a fresh 2.5.1 package to your server
    - modify wp-config.php
    - enter admin, enable default theme, check if everything is OK, verify the public view of the site
    - then, one by one, upload, enable and configure your plugins, checking the site and publish functions everytime
    - finally enable your theme

    ZuesII,

    I have tried this with Cuzoogle's install and even attempted to create a /dev directory with a fresh install of 2.5.1 and I still get the script error. I'm beginning to think there might be a database issue, because a fresh install w/ new database works, but if you connect to his database it gives the error. Any thoughts?

  24. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    and I still get the script error.

    What script error, exactly?

  25. GMB
    Member
    Posted 6 years ago #

  26. adambundy
    Member
    Posted 6 years ago #

    Otto 42- Thank you- this does appear to be a problem with FTP client not sufficiently over-writing files in wp-admin and -includes. For me, deleting those directories from the server and re-uploading the new versions has fixed the prob. Thanks!

  27. GMB
    Member
    Posted 6 years ago #

    I am going to try again to see if I might have missed a step.

  28. athenablue
    Member
    Posted 6 years ago #

    I had the same problem as everyone, and I tried deleting the the wp-admin and includes folders and uploading them again (as the upgrade guide says). That didn't do it, so I deleted all the main wp files, modified and used the new wp-config file, and uploaded the 2.5.1 install main directory wp files. Basically, I did new install in a shortened form. I do hope the developers get this resolved, but thanks for the help.

  29. GMB
    Member
    Posted 6 years ago #

    I did exactly as Zeus suggested above and came away with the same script error when writing a new post as before. I don't know what is wrong with this installation, but the only common denominator is the database. I'm of the opinion that something in the database is corrupt.

  30. ian.tempest
    Member
    Posted 6 years ago #

    Hi,

    I'm pretty new to WordPress, but I've encountered this problem too since upgrading to 2.5.1. I haven't looked into why this problem is occuring, but I do have a quick/dirty workaround to disable autosave completely.

    Make a backup copy of /wp-includes/js/autosave.js, then after line 135:

    var autosave = function() {

    add the line:

    return;

    Fingers crossed for an official patch soon!

Topic Closed

This topic has been closed to new replies.

About this Topic