WordPress.org

Ready to get started?Download WordPress

Forums

Probably on permissions (3 posts)

  1. pietros
    Member
    Posted 9 years ago #

    So,
    my wp is starting to work, and I continued studying. The wp works on all its basic functionality, but it seem not to be able to do anything fancy.
    In particular even if I told it that I want my permalink to be of a particular form (with the name) it keep on giving me the permalink in the form of ID=#
    Also no plugin seem to work. I install them, I click on activate them. It sais: plugin activated...
    but inder, in the list of plugins nothing changes. The button on the right still says: 'Activate'.
    (I assume it should switch to: 'Deactivate')
    I wondered what could be the cause of all this, and I reached the conclusion that I probably haven't set up the right permissions (chmod) for the files or the directories.
    That would make sense, if the wp does not have the permissions to modify his settings, everything would work except changing the settings.
    So here is the question, which chmod should be set, for which file to give enough flexibility to be able to activate and deactivate the plugins. And to modify the permalink.
    Many thanks,
    Pietro

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Where is your .htaccess file that you have created ? It should be in the same directory as wp-layout.css
    Does your host have 'mod_rewrite' enabled ?
    Plugins - they should work as you describe. There is no particular permissions issue for the folder /wp-content/plugins/, but you could set it top 755 / 766 or 777 if you wish.
    Does the Hello Dolly plugin work ? (It's a default plugin included)

  3. pietros
    Member
    Posted 9 years ago #

    Sorry, if I answered slowly, but my computer crashed in the meantime. I suspect my windows is cultivating a whole ecology of viruses.
    .htaccess is in the main directory. The one where the index.php is (and the css file too).
    The redirect works fine (I asked my host).
    If I deduce what the name of the post should be, then I can write by hand the url and I am correctly redirected there. The problem is that there seem to be no automatic way to get this url written automatically.
    When I use the function <? the_permalink()
    I am always answered with index.php?p=#
    with # = the number of the post
    Same thing with the categories.
    No the Hello Dolly plugin does not work, nor any other.
    When I click on activate he says:
    "activated"
    but under he keeps on asking me for each plugin if I want to activate it...
    _also_for_the_one_that_he _has_supposedly_activated.
    I assume he should instead ask:
    "Deactivate"
    The permissions were already as you told me to make them.
    Please let me know if I can give you more info.
    The blog address is http://blog.pietrosperoni.it
    Many thanks for your time,
    Pietro

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.