WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Twelve
Probably a bug in header.php (12 posts)

  1. Fabrizio Pivari
    Member
    Posted 1 year ago #

    I use Twenty-Twelve 1.1.1 with wp 3.5
    I've only with Twenty-Twelve (with version 1.0, 1.1, 1.1.1) the same problem on 2 blogs
    http://www.cloud-tech.eu/
    http://www.pivari.com/
    See e.g. the page
    http://www.cloud-tech.eu/about/
    You can see that title is
    <title>AboutCloud Tech | Cloud Tech</title>

    | Cloud Tech is of All in one seo plugin

    and I think

    AboutCloud Tech i of the theme

    With other wp themes (ten and eleven) I have simple About

    What's the problem?

    Fabrizio

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Try switching themes to Twenty Eleven to see whether the problem persists.

  3. martinjharvey
    Member
    Posted 1 year ago #

    You could also try disabling the All In One SEO plugin also.

  4. Fabrizio Pivari
    Member
    Posted 1 year ago #

    > You could also try disabling the All In One SEO plugin also.
    Made. This is not the problem.

  5. Fabrizio Pivari
    Member
    Posted 1 year ago #

    > Try switching themes to Twenty Eleven to see whether the problem persists.

    With Twenty Eleven I have About | Cloud Tech
    not AboutCloud Tech !

  6. Fabrizio Pivari
    Member
    Posted 1 year ago #

    I've seen that the title code in twenty twelve is very different (only 1 line) from twenty eleven and twenty ten.
    I'm not a devoloper and I don't know very well php.

  7. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    this is all the code related to the meta title in Twenty Twelve:

    <title><?php wp_title( '|', true, 'right' ); ?></title>

    just for testing, try to replace it with:

    <title><?php wp_title(); ?></title>
  8. Fabrizio Pivari
    Member
    Posted 1 year ago #

    I made. Strange. Now the title is
    <title> » AboutCloud Tech</title>

  9. Fabrizio Pivari
    Member
    Posted 1 year ago #

    » ???

  10. Fabrizio Pivari
    Member
    Posted 1 year ago #

    > You could also try disabling the All In One SEO plugin also.
    I've remade this and now it seems to work!
    Probably in my previous test I was a problem with cache.

  11. martinjharvey
    Member
    Posted 1 year ago #

    Try reading the codex entry for wp_title();
    Function Reference/wp title

    Maybe something here will format the title as you require. One point to make though, is although I'm no SEO expert, I did think that the way that the title is being formatted with the page name before the website name was actually more SEO friendly?

    I might be wrong, but if it's not what you want then I suppose that doesn't really matter ;)

  12. voeslav
    Member
    Posted 1 year ago #

    Here's the answer to your question.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.