WordPress.org

Ready to get started?Download WordPress

Forums

Pretty Link Lite
[resolved] Pro Version not Tweeting Scheduled Posts (23 posts)

  1. dbirlew
    Member
    Posted 10 months ago #

    The other problem is that the customer service page at prettylinkpro.com has a redirect and is unavailable, and so sadly I must post this here. :(

    For months now Pretty Link Pro has stopped working as it once did. Although I've added my Twitter account on the pro options page and PrettyLinkPro is still authorized on my Twitter settings, PrliPro will not auto-tweet scheduled posts when they publish. Just to confirm, I've authenticated my Twitter account, checked "Create Pretty Links for Posts", set them to create in a group, "Show Social Network Button Bar on Posts" and "Automatically post to Twitter when a Post is published" both checked.

    Also, there used to be a post meta panel that allowed you to customize the tweet of a scheduled post, this is now gone.

    How do I fix the plugin so that it will tweet scheduled posts again? My client is pissed.

    http://wordpress.org/extend/plugins/pretty-link/

  2. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    Hey dbirlew,
    sorry for the troubles. Looks like twitter just changed their API version, and discontinued the old version instead of keeping it live for legacy code. Anyways, we'll have this fixed in the next version of Pretty Link, but if you need to get this working now open the .../wp-content/plugins/pretty-link/pro/includes/php/abraham-twitteroauth/PrliTwitterOAuth.php

    And find:
    public $host = "https://api.twitter.com/1/";
    and change it to:
    public $host = "https://api.twitter.com/1.1/";
    and save.

  3. dbirlew
    Member
    Posted 9 months ago #

    Oh, well, that was nice of Twitter now wasn't it? ;) Thank you for the response cartpauj I have made the change to my client's site and hopefully we'll see the difference when her next post goes out, probably tomorrow. I'll let you know otherwise, but thanks!

  4. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    No problem. Let me know if that doesn't fix the issue, but in my tests it was working well.

  5. dbirlew
    Member
    Posted 9 months ago #

    I'm afraid the problem persists with scheduled posts not auto-tweeting. If you publish a post regularly then the auto-tweet fires right away, I tested it on my dev site with another Twitter account, so updating the Twitter API folder fixed that much. However if a post is scheduled, the pretty link is not created and an auto-tweet does not go out when the scheduled post goes live. Instead when you edit that post, the Pretty Link meta box shows the following message: "A Pretty Link hasn't been generated for this entry yet. Click "Update Post" to generate." You must then click update, but even then an auto-tweet does not fire. The client has to go to the post and click the share button on the social bookmark bar. So we obviously need to look at the logic for tweet creation, do you happen to know where that code resides? Thanks again for your help.

  6. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    I think I found the issue, but if you can test it, that would be great.
    In the pretty-link/pro/pretty-link-pro.php file around line #700:

    if( 'page' == $post->post_type and !current_user_can( 'edit_page', $post_id ) )
        return $post_id;
    
      if( 'post' == $post->post_type and !current_user_can( 'edit_post', $post_id ) )
        return $post_id;

    Change those to:

    if( 'page' == $post->post_type and !current_user_can( 'edit_page', $post_id ) and $type != 'auto' )
        return $post_id;
    
      if( 'post' == $post->post_type and !current_user_can( 'edit_post', $post_id ) and $type != 'auto' )
        return $post_id;
  7. themophiles
    Member
    Posted 9 months ago #

    please tell if I can make back up of all my links that I have used on my website themophiles.com by pretty link lite as I want to delete and re-install this plugin

  8. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    Pretty Link Pro has an import export feature available you can do this with. Otherwise you'll have to manually back them up using something like phpMyAdmin.

  9. dbirlew
    Member
    Posted 9 months ago #

    @cartpauj Unfortunately I made the above changes to the file on Friday, but today my client says they still had to update the scheduled post after it went live in order to create the Pretty Link. I'm going to test it on a test site a little later, but until then is there anything else you can think of to fix auto-tweet on scheduled post update? Thanks.

  10. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    Let me know how your test comes out, it's working for me in my tests now. I'll wait to hear back from you.

  11. dbirlew
    Member
    Posted 9 months ago #

    I set up PrLiPro on another site and scheduled a post. The plugin created the Pretty Link when the post went live, it wasn't doing that previously so that part is fixed. However the plugin did not publish the title and link to Twitter. So perhaps since the API has changed there is some new hook for auto-tweeting?

    Also, so I remove and reconnect the Twitter account? Might that help at all?

  12. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    You can try reconnecting to twitter. I just tested this again myself and it worked fine. The post was scheduled, I checked a few hours later (after it should've been published) and it was posted to my twitter account without issue.

  13. dbirlew
    Member
    Posted 9 months ago #

    I deactivated the Twitter account by clicking the little x next to it, then saved the options. When I returned to the Twitter Options I could see the following error above Add a Twitter Account button:

    Warning: Invalid argument supplied for foreach() in /home/danbir5/public_html/lvmb/wp-content/plugins/pretty-link/pro/classes/views/prlipro-options/form.php on line 177

    When I clicked the button and authorized the app on Twitter, it returned me to my site. However, it was a white PHP error page with the following errors:

    Warning: Invalid argument supplied for foreach() in /home/danbir5/public_html/lvmb/wp-content/plugins/pretty-link/pro/pretty-link-pro.php on line 1642

    Warning: Cannot modify header information - headers already sent by (output started at /home/danbir5/public_html/lvmb/wp-content/plugins/pretty-link/pro/pretty-link-pro.php:1642) in /home/danbir5/public_html/lvmb/wp-content/plugins/pretty-link/pro/pretty-link-pro.php on line 1673

    Just an update after this occurred, I wonder if it sheds some light. I will schedule another post and update you tomorrow on whether it auto-tweets yet.

  14. dbirlew
    Member
    Posted 9 months ago #

    Posts are not auto-tweeting, neither on Publish or when a schdeduled post is published. Please advise, thanks.

  15. gaplauche
    Member
    Posted 9 months ago #

    I can confirm the same problems and the same warning with Pretty Link Pro on my website, prometheus-unbound.org. Is there a fix imminent?

  16. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

    I cannot duplicate the auto-tweeting issue on scheduled posts, but the other two issues will be fixed for sure in the next release.

  17. gaplauche
    Member
    Posted 9 months ago #

    Yeah, my posts aren't auto-tweeting at all.

  18. cartpauj
    Member
    Plugin Author

    Posted 9 months ago #

  19. dbirlew
    Member
    Posted 9 months ago #

    Those fixes did not help me with this issue; did you read my last post above?

    http://wordpress.org/support/topic/pro-version-not-tweeting-scheduled-posts?replies=18#post-4380738

  20. cartpauj
    Member
    Plugin Author

    Posted 8 months ago #

    dbirlew, I'm sorry but I can't duplicate this at all. Blair (Developer of Pretty Link) is on a family vacation right now, but I'll point him to this thread when he gets back next week so he can help troubleshoot it further for you. If you haven't heard anything by Wed, bump this thread again to remind me :)

  21. sunkast
    Member
    Posted 7 months ago #

    Has this been fixed yet? I've tried both of the above fixes but still cannot get auto tweeting to work. It says it has been tweeted, but never actually does.

  22. sunkast
    Member
    Posted 7 months ago #

    I think I've got this sorted out. Tried a new post and it worked.

  23. sunkast
    Member
    Posted 7 months ago #

    Okay so it doesn't work after all. Every post that I've made in the last 4 days has failed to tweet on publish. Also scheduled posts are not creating the pretty link when published unless I go back to the post and click update.

    When will scheduled posts and auto tweeting be fixed? I'm very disappointed paying for a plugin that does not work as advertised.

Reply

You must log in to post.

About this Plugin

About this Topic