WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Privacy settings in WordPress (7 posts)

  1. sud
    Member
    Posted 4 years ago #

    Please guys help. im having some major issues with wordpress and the robot.txt and blog privacy options.

    a couple of days ago i change my privacy setting in wordpress to block search engines as i was doing major updates to my website such as changing the structure around and stuff.

    Now today i went to enable it back but it changes nothing under settings - privacy options. The reason how i know this is A: google webmaster tools and also my google ads aint comming up with relevant ads. Finally i tried messing with a number of robots.txt plugins none has been able to undo this change i even thought it could be something to do with the .htacess as i have rewrite on for /categories turned it of and all plugin still no diffrence.
    So whats next, can i manually edit this without the Wp-admin sections. i dont want to delete my whole blog and start fresh. Any other ways around this.

  2. alism
    Member
    Posted 4 years ago #

    Is the robots.txt file writable?

    (can you post a link to your site?)

  3. sud
    Member
    Posted 4 years ago #

    yea sure .. its modsandhacks.net, its weird how ive changed the robot.txt by google aint picking it up still says thats is disallowing. all suggestions appreciated.

  4. sud
    Member
    Posted 4 years ago #

    i tried deleting blog and trying again - no luck just PSA ads and no index, ive tried every robots.txt script under the sun. it seems as though the private and public setting in the privacy section has no affect, i used webmaster tools a couple days back and it was fine. Does anyone know what function of php file the privacy settings edit?

  5. alism
    Member
    Posted 4 years ago #

    Your robots.txt looks fine to me. I don't think there is an 'allow' in robots.txt, as that's kinda assumed anyway as it's an exclusion protocol. But I wouldn't have thought any of the major search engines would have a problem with it as it is.

    Perhaps I'm missing something, but I can't see any obvious reason why Google wouldn't be able to crawl your pages. You may just need to give it some time. Perhaps see if there's any settings in your Adsense account you need to change?

  6. sud
    Member
    Posted 4 years ago #

    i figured it out, couldnt find it on the internet so had to figure it out myself. it was basically my servers trash files needed to be deleted, which was under the legacy file manager in Cpanel. thanks anyway

  7. felo
    Member
    Posted 3 years ago #

    Hi, I've the same problem, turn invisible to search engines in my brand new blog, then after have all the content as I would like it to be seen by search engines, turn visible ON for the search engines, empty my server trash but.... nothing I just can get Google to index my brand new blog.

    Please Help!

Topic Closed

This topic has been closed to new replies.

About this Topic