WordPress.org

Ready to get started?Download WordPress

Forums

Privacy setting - "Save changes" feature not working and site remained "blocked" (18 posts)

  1. Goh Meng Kiang
    Member
    Posted 2 years ago #

    When i setup my website , i set the privacy setting to "BLOCK" the sites from the search engine . Now that i have filled up the site with relevant content , i want to "UNBLOCK" the site . I can't seem to "unblock" it as the "SAVE CHANGES " feature in the privacy setting now does not seem to work and the site remained "Blocked" . Anyone has any idea what could possibly be the problem ?

  2. Lollygreen
    Member
    Posted 1 year ago #

    I am having this same problem. I used the privacy settings while building my blog Diabetes2.Biz to ask search engines not to index the website and now despite changing the setting back to allow search engines to index the site my site still shows that it is unable to be indexed, I tested the settings on another website and it too now will not change back.

    I used SEO Doctor for Firefox to check my sites for indexing.

    The only way I can change it all is to delete my entire WordPress installation and start all over again, which when tested works fine, but I have a website all built that would take to logn to do that all over again.

    Any Suggestions?

  3. egado
    Member
    Posted 1 year ago #

    Can you pls post the blog url?...

  4. Lollygreen
    Member
    Posted 1 year ago #

    Below is the link, if you can help at all it would be great, I have spent hours trying to make it work.

    Diabetes2.Biz

    With Gratitude

    Lolly

  5. egado
    Member
    Posted 1 year ago #

    hm... i can't see any problems...

    type site:http://diabetes2.biz in your google search field... your website is already be indexed...

    Where you get the msg that your site cant be indexed? pls try STRG + F5 while seeing that msg in your backend or?

  6. Lollygreen
    Member
    Posted 1 year ago #

    Hi Egado,

    Thank you for making suggestions.

    Yes I can see those indexed pages, that site was indexed before I used the privacy settings, when I now use SEO Doctor in firefox it says SEO Doctor will show a special 'no-trespassing' icon when the current page is not indexable at all by search engines,and it does show that symbol.

    I first had the problem with a site that I built for someone on Racehorsesyndicationopportunity.com
    I used the privacy setting to hide it, then when I tried to unhide it, it stayed hidden. So I recreated the problem on my Diabetes2.Biz site.

    I did what you said with http://www.Racehorsesyndicationopportunity.com and it shows up as not having being indexed.

    Any other suggestions?

    With Gratitude

    Lolly

  7. egado
    Member
    Posted 1 year ago #

    i have installed this plugin now and tested your site:
    http://www.egado.de/wp-support/seo-doctor.png

    seems to be ok - or?

  8. Lollygreen
    Member
    Posted 1 year ago #

    Thanks for trying it out, I have noticed that the http://www.Diabetes2.Biz one now has a red flag, which is great but the http://www.Racehorsesyndicationopportunity.com is still showing the no trespassing sign, did you check that oneThanks for trying it out, I have noticed that the Diabetes2.Biz one now has a red flag, which is great but the http://www.Racehorsesyndicationopportunity.com is still showing the no trespassing sign, did you check that one with SEO Doctor?

    I keep clearing my cache and pressing F5 in the hope that it is somehow just my computer, but my partner is having the same results on a two different computers.

    With Gratitude

    Lolly

  9. egado
    Member
    Posted 1 year ago #

    Pls delete that firefox plugin...it is that stupid...
    Change your canonical from http://racehorsesyndicationopportunity.com...

    from

    <link rel="canonical" href="http://racehorsesyndicationopportunity.com" />

    to

    <link rel="canonical" href="http://racehorsesyndicationopportunity.com/" />

    and the seo doctor firefox plugin will be happy... but, deinstall that plugin an make use of google webmaster tools :) your site was ok for google... no trouble... everything fine, just before the change obove ;)

  10. Lollygreen
    Member
    Posted 1 year ago #

    Hi,

    So you think the SEO Doctor plugin is faulty and my page will be indexed soon.

    Thank you so much for taking the time to find out what was causing it to show my page as being unable to be indexed, I will contact SEO Doctor and tell him about what has happened so he can make some modifications.

    You are awesome thank you so much!

    With Gratitude

    Lorraine

  11. Goh Meng Kiang
    Member
    Posted 1 year ago #

    HI ,
    I had this problem and found that ONE of the many plugins that i had was the cause . I have to disable 1 plugin at a time to isolate which is the cause .
    Good that you have your problem identified too

  12. Lollygreen
    Member
    Posted 1 year ago #

    Sorry to be dumb but where is the Canonical located, I am looking inside appearance editor and have not yet found it. Could you please point me in the right direction.

    And thanks again for your help.

    With Gratitude

    Lolly

  13. egado
    Member
    Posted 1 year ago #

    well... but you better correct your canonical tag as shown above... or delete it and try the google webmaster tools https://www.google.com/webmasters/tools

    but i guess that canonical tag wasn the reason for google... but better change it :)

    //EDIT
    I don't know how your canonical tag is beeing created... like from a addon, or directly in your header.php... i cant see it... :(

  14. Lollygreen
    Member
    Posted 1 year ago #

    Thanks again, I will try and figure out where the canonical tag and make the changes and will use google webmaster tools.

    Thanks again!

    With Gratitude

    Lolly

  15. Lollygreen
    Member
    Posted 1 year ago #

    Hi,

    I just noticed that both

    From

    <link rel="canonical" href="http://racehorsesyndicationopportunity.com" />

    and

    To

    <link rel="canonical" href="http://racehorsesyndicationopportunity.com" />

    are both the same.

    what should the to one have?

    With Gratitude

    Lolly

  16. Lollygreen
    Member
    Posted 1 year ago #

    Hi,

    Found the canonical tab that was causing the problem in the header.php and removed it, it was in a different place and was a much shorter code, but it all works now, thank you so much for all your help.

    SEO Doctor I am still happy with as I would not have known the page was a 'dont index' without it.

    You are so appreciated!

    With Gratitude

    Lolly

  17. egado
    Member
    Posted 1 year ago #

    There was missing the trailing slash / after .com

    wrong
    <link rel="canonical" href="http://racehorsesyndicationopportunity.com" />

    right
    <link rel="canonical" href="http://racehorsesyndicationopportunity.com/" />

  18. charmasia
    Member
    Posted 1 year ago #

    Thank you for sharing !

    Vietnam charming

Topic Closed

This topic has been closed to new replies.

About this Topic