WordPress.org

Ready to get started?Download WordPress

Forums

Genesis eNews Extended
Privacy Checkbox layout issue (10 posts)

  1. venethia
    Member
    Posted 10 months ago #

    Hi,

    I'm using Aweber and I added a privacy checkbox to my form as required field.

    Checkbox is ok but the text isn't in the same line, it's under the checkbox.

    Any suggestions?

    Thanks.

    http://wordpress.org/plugins/genesis-enews-extended/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Can you include a link to your site?

    Since you're adding a new form field that your theme wasn't expecting, there is no styling included for it. You'll need to add styling to your theme to make it look pretty.

  3. venethia
    Member
    Posted 10 months ago #

    The site is in maintenance mode.

    Take a look at this screenshot, click here.

    I'm using Genesis with Metro Pro Child theme.

    Thank you very much.

  4. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I'll get to this when I get time to setup a test site with that theme. It's really helpful to have the site live for debugging, since I'll only be using Chrome's Inspect Element tool to try some small CSS edits to verify the right course of action.

  5. venethia
    Member
    Posted 10 months ago #

    The site is live now :-)

  6. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I'd start by adding this to your theme's style.css (or using a Custom CSS option, like what is in Jetpack):

    .enews input[type="checkbox"] {
    width: auto;
    margin-right: 4px;

    As it comes, the checkbox has a width: 100% rule assigned to it, so it is "taking" the full width of the box, which is why the text is forced below.

    Cheers!

  7. venethia
    Member
    Posted 10 months ago #

    It doesn't works.

    Checkbox still in the middle and text below.

    Hidden field code in widget :

    <label><input type="checkbox" name="custom privacy" value="yes" /> Barrando la casella confermi di aver letto la normativa sulla privacy</label>

  8. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Hi,

    You may need to clear your browser's cache as the text is along side of the checkbox when I view it.

  9. venethia
    Member
    Posted 10 months ago #

    Here are the screenshot after cleared cache and cookies of all browsers.

    Internet Explorer 9

  10. venethia
    Member
    Posted 10 months ago #

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.