WordPress.org

Ready to get started?Download WordPress

Forums

Cleverness To-Do List
[resolved] Priority Not Showing (11 posts)

  1. ivbscorp
    Member
    Posted 1 year ago #

    I have a couple problems. First is showing the priority option on the front end for a user. This is what I've got:

    [todoadmin title="Task List" priorities=1 deadline=1 progress=1 categories="afv"]

    Did I miss something? It shows in the backend of wordpress for my admin login but not in the page with this code.

    It does show the deadline and progress bar but the menu bar is jumbled and stacked instead of side by side so it reads Item, Progress, Deadline on top of eachother and then Action to the side. When a task is entered in is it possible to make these line up nice as a table?

    Also the progress bar is right on top of the Item Box. Can we position this just a bit lower? I know these are knit-picky requests but this is such a great tool, I want it to look just right.

    Thanks much!

    http://wordpress.org/extend/plugins/cleverness-to-do-list/

  2. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    For the todoadmin shortcode, it is priority=1 instead of priorities.

    The display of the todoadmin shortcode doesn't have any default styles except the ones necessary for the progress bar to avoid conflicting with themes. It uses an HTML table and form and has plenty of CSS classes in case you need to override your theme styles.

  3. ivbscorp
    Member
    Posted 1 year ago #

    Thanks so much for the quick reply! Must have gotten confused with the other example that showed priorities plural. Thanks.

    Did find the css and fixed the padding below the progress bar. Thanks again!

    Still trying to fix the selector boxes to show in-line right to left instead of on top of each other though. If you would, I'm sure other people might appreciate it as well, a little run-down on where to find this styling and what to change? I have a feeling its in the "selector2.css" and has something to do with the "position: relative" option, maybe need fixed width and a text wrap? but not sure where to go from there.

    Minimal CSS knowledge here but enough to follow directions. Again, knit-picky request but just something that would really improve the look/feel of this GREAT plugin! No rush but when you have the time, others might also be wondering how to do this. THANKS!

  4. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    Is the selector2.css you mentioned cleverness-to-do-list-select2.css? That only styles the assign users dropdown box.

    Is it the table headings that aren't lined up properly? The only styling I do on them is to add the little arrow for sorting. Anything else is probably coming from your theme. The CSS selector for that is table#todo-list thead tr th.

  5. ivbscorp
    Member
    Posted 1 year ago #

    Wow yeah, then it isn't the styling's fault. Thanks, I'll try to see if I can figure out what in the theme is making it do that.

  6. ivbscorp
    Member
    Posted 1 year ago #

    Do you think it has to do with theme being responsive?

  7. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    It's certainly possible. The theme may be doing something with tables to make sure all the data fits on the screen.

  8. ivbscorp
    Member
    Posted 1 year ago #

    That sounds right to me, definitely beyond my depth to fix and a good excuse to just leave it alone. Thanks for all your help Cindy!

  9. ivbscorp
    Member
    Posted 1 year ago #

    This just occurred to me - is it possible to just remove those table headings completely?

    This is a screenshot: http://www.ivbscorp.com/wp-content/uploads/2013/02/screenshot.png

    You can also see the "Normal50%02/23/2013" right on top of each other, is that also the theme or is there a fix for that?

  10. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, it's definitely possible to remove them using CSS.
    table#todo-list thead tr th { display: none; } in your CSS should work.

    Normally a theme adds some sort of table padding, but there doesn't appear to be any in yours which is why the Normal50%etc is all run together.

    Try adding `table#todo-list td { padding: 5px; } in your CSS. Change the padding value to whatever looks best.

  11. ivbscorp
    Member
    Posted 1 year ago #

    YOU ARE AN ANGEL! Thank you so much its absolutely perfect now. I'm gonna buy you a coffee - you're the best!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.