WordPress.org

Ready to get started?Download WordPress

Forums

"Previous Entries" link on Manage pages directs to blog (5 posts)

  1. ladycrow
    Member
    Posted 6 years ago #

    I have an issue I haven't been able to figure out.
    When I am managing pages or posts in my dashboard, if the current post selection contains more than 1 page of posts, the "Previous Entries" link goes to my blog rather than page 2 of the entries in the manager.

    IE if I select March 2003 which has more than 1 page of entries, and want to view the rest of the entries in the editor (page 2) it brings me to that page in my blog (page 2 of March 2003) instead.

    It's not specific to a theme and it's not due to the permalinks.

  2. ladycrow
    Member
    Posted 6 years ago #

    I'm suspecting this has to do with the .htaccess which I'm having some issues with.

    If I use the custom permalinks I want, it tells me it can't edit my .htaccess even though the permissions are set correctly and it does exist. I'm not entirely sure which directory the file should go in and I see comments saying it should be in either the root directory "/" or the wp root directory "wp/" and even some that say it should be in "wp-admin" so I've tried it everywhere.

    I also cannot access it from the files manager because it apparently doesn't exist (it does).

    So I try to edit it via FTP; however, when I do this, I cannot access my site. I get a 403 error.

    Still, when I use default permalinks and there's nothing to add to the .htaccess, the link directs to the blog.

  3. ladycrow
    Member
    Posted 6 years ago #

    I think I have discovered the culprit. I had wanted my blog to be named blog.php (for now) in another directory (the WP files being in wp/) except this was adding /blog.php/ to my dashboard links.

    So I can just set it up at wp/index.php except when I go into my dashboard options and try to change it back to index.php, I am directed to another 403 error. What's going on?

  4. ladycrow
    Member
    Posted 6 years ago #

    Google showed me the answer to the 403 issue (.htaccess) so I changed it to index.php within the WP folder and everything works. I guess you just can't rename your blog page anything but index.php?

  5. Janice
    Member
    Posted 6 years ago #

    I had the exact same problem. Solved by going to Options and removing the www from the blog address.

Topic Closed

This topic has been closed to new replies.

About this Topic