WordPress.org

Ready to get started?Download WordPress

Forums

'Previous entries' gives 404 (47 posts)

  1. Benjette
    Member
    Posted 6 years ago #

    Just realized when I click on Previous entries at the bottom of my index page, it goes to /page/2/ but it's a 404... any ideas?

    http://retardedinlove.com

  2. ebizer
    Member
    Posted 6 years ago #

    I wish I had an answer for you, but I'm experiencing the same thing. :-(

  3. ebizer
    Member
    Posted 6 years ago #

    Looked through forum and discovered it was a Permalink Redirect plugin problem. Deactivated and all is working fine now. Could this also be your problem?

  4. Benjette
    Member
    Posted 6 years ago #

    Nope, I don't have any extra plug-ins installed.

  5. Benjette
    Member
    Posted 6 years ago #

    Bump

  6. whooami
    Member
    Posted 6 years ago #

    and what happens if you switch to the default theme, Benjette? And whats in your .htaccess?

    Strangely, WP is puking up a 404 when I try to bring up your .htaccess .. that a very odd behaviour. It should not be doing that.

  7. infinitewarrior
    Member
    Posted 6 years ago #

    Benjette, can you see page 2 if you are logged into the admin panel?

    I am having the same problem with my links page. Oddly, if I am not logged in, the page redirects as a 404. If I am logged in, the page renders normally. (And, of course, that means no one else anywhere can access it.)

    There are no if_user logged in variables anywhere on the page. I have deactivated/removed plugins (no conflicts), reset permalink options (no improvement) and it still redirects to a 404.

    This began with the upgrade to 2.3.

  8. whooami
    Member
    Posted 6 years ago #

    are the posts on page 2 published, infinitewarrior?

    I happened to notice that publishing seems to be a more than a one click action now, and consequently, ppl think theyre publishing while they're really not.

  9. infinitewarrior
    Member
    Posted 6 years ago #

    I've no issues w/page 2 as Benjette does, whooami. Everything works fine for me with the exception of a single Page, which is in 'published' mode. (Good thought, though.)

  10. Benjette
    Member
    Posted 6 years ago #

    There aren't enough posts for a page 2 to be active in the default theme, so I'm not sure about that.

    I can't see the pages even when I'm logged in.

    This is my htaccess:

    # -FrontPage-
    
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName beeteedubs.com
    AuthUserFile /home/beeteedu/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/beeteedu/public_html/_vti_pvt/service.grp
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  11. jk079
    Member
    Posted 6 years ago #

    I'm having the problem that Benjette describes as well. I don't know if it's linked to 2.5, since my blog is pretty new and there wasn't any pagination happening earlier.

    Basically, my previous posts links correctly take me to http://joykim.net/blog/page/2/, but that returns a 404.

    Inactivating plugins did not have any effect.

    I tried the solution here at:
    http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems
    but it did not have any effect either.

    My .htaccess file contains the following now:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Any idea what's up?

    ETA: I tried changing back to the default theme, and that didn't work as well.

  12. jk079
    Member
    Posted 6 years ago #

    Update: I fixed my problem by changing my permalink structure from:

    /blog/%postname%/

    to:

    /posts/%postname%/

    Guess the old structure was interfering with the pagination somehow.

  13. Aarne Toompark
    Member
    Posted 6 years ago #

    Same error for me. All pages and sub-pages will give 404 error.

    Changing to default theme will not help.

    My current permalink structure is Custom structure /index.php/%postname%/ and it has been working from version 1.56.

    Changing permalink structure to default will solve 404-problem but this is not a solution. Same thing happens in multiple blogs I maintain.

  14. jk079
    Member
    Posted 6 years ago #

    If it helps, I used this tutorial to change my permalinks without breaking old links:
    http://www.tubetorial.com/change-wordpress-blog-links-without-breaking-them/

    It's basically a guide to using Dean’s Permalinks Migration Plugin.

  15. dan13l
    Member
    Posted 6 years ago #

    Well, I can't get this to work either.

    2.5 powered blog, I've tried the suggestions above. It just doesn't work.

  16. mdelma
    Member
    Posted 6 years ago #

    I'm experiencing the same problem. I just upgraded to 2.5 and still my "previous entries" link on the main page doesn't work. All the other permalinks are fine, and pagination of the posts in subpages (e.g. categories, or archives) are ok, as you can see for instance from:

    http://www.bivacco.net/marco/categorie/comunicazione/page/2/ (works fine)

    while http://www.bivacco.net/marco/page/2/ returns a 404

    If I change my permalink structure to PATHINFO the main page pagination works, but I'd really like to keep 'index.php' out of my links :-(

    BTW, I just noticed that Benjette apparently solved her problem: http://retardedinlove.com/page/2/ loads fine... Benjette, any magic recipe?

  17. rfp
    Member
    Posted 6 years ago #

    Hi,

    while benjette don't post the magic recipe, I kinda solve this problem.

    Please check http://wordpress.org/support/topic/167305.

    HTH

  18. DREAM SIZE
    Member
    Posted 6 years ago #

  19. jrm213
    Member
    Posted 6 years ago #

    Hi, just wanted to post that we were having this issue and solved it a little differently. I don't know why one thing works for some and not for others but here was our situation.

    our permalink structure is /%category%/%postname%

    http://www.oursite.com/news listed all of our news category posts and at the bottom had a link for previous posts that would always give a 404 if you clicked it. That link looked like http://www.oursite.com/news/page/2

    Change our navigation to access the news page to be http://www.oursite.com/category/news resolved the issue. It made the link at the bottom of the page be http://www.oursite.com/category/news/page/2 and from that point on all the previous and next links worked just fine.

    hope this helps the next person that comes along!

  20. gimperdaniel
    Member
    Posted 5 years ago #

    I have tried all of the above and neither one has worked for me. I am having exactly the same problem as described for several people here...

    permalink structure: /%category%/%postname%

    In this case...

    http://www.mypage.com/news

    This calls the archive.php

    archive.php has an include: if (in_category("news")) INSERT news_arquive.php

    In news_archive.php I have the following code:

    <?php $page = (get_query_var('paged')) ? get_query_var('paged') : 1;?>
    						<?php query_posts("cat=7&showposts=5&paged=$page");?>

    And then in the bottom I have the previous and next links. They point to:

    http://www.mypage.com/news/page/2

    But that doesn't seem to exist so I get a 404 page.

    Question is.. WHY?

  21. gimperdaniel
    Member
    Posted 5 years ago #

    everything i described above works just fine on index.php (home page)...

    why doesn't it work on the news category?

    The index.php is almost identical to the news category page except that it has other images before the posts.

  22. gimperdaniel
    Member
    Posted 5 years ago #

    and it also works if I add an category base to the permalink structure... but I really dont want a category base...

  23. shadow379
    Member
    Posted 5 years ago #

    I changed my Permalink structure from "default" to "date and name based" and started getting 404 errors when clicking on Previous Entries. Changing it back to "default" fixed the problem. I'm on WordPress version 2.3.3.

  24. csoul
    Member
    Posted 5 years ago #

    I'm having the same issue in 2.5.1

    Permalink structure /%category%/%postname%/

    /page/2/ leads to a 404 error *unless* the front page and the second page show the same number of posts (3, in this case.) That, need I say, is annoying as heck. I'd *much* rather show 3 on the front page and 10 on the rest of the pages.

    Pagination worked fine under the default permalink structure. I've completely rebuilt htaccess and mucked about with all the other suggestions I could find, with no luck.

    My major question is the same as gimperdaniel's: WHY is it doing this? My minor question is how do I make it stop?

    EDIT:
    Could this have something to do with a mismatch between "showposts=3" in the index.php template and a "Pages show at most 10" setting? Removing the "showposts" setting from the index.php file also seems to fix it.

    EDIT (again):
    Adding a conditional ( is_front_page() && !is_paged() ) to the query string, with the front page using "showposts=3" and everything else omitting the restriction, doesn't seem to solve the problem either.

  25. jk079
    Member
    Posted 5 years ago #

    And mine has stopped working again! Fun.

    My site: http://joykim.net

    I have a custom front page, and my blog at:
    http://joykim.net/blog

    Therefore, the second page should be at:
    http://joykim.net/blog/page/2

    That returns a 404.

    What works instead--the url where page 2 would be if I did not have a custom front page:
    http://joykim.net/page/2/

    The category pages paginate correctly. For example:
    http://joykim.net/posts/category/manga/page/2/

    Anyway, this makes me think this is all linked to my having a custom front page--any ideas?

  26. buchannon
    Member
    Posted 5 years ago #

    Did you guys figure anything out on this? I'm kind of in the opposite situation than you where I want 10 posts-per-page on the home page, and only 3 posts-per-page on a category page.

    I've created a template category file, "category-4.php" in my theme and followed the guide here:
    http://www.nathanrice.net/blog/creating-a-blog-page-with-paging/

    When I go to mysite.com/category/mycategory/page/2/ it displays the second page of posts but the number is off. No matter what I do, this custom category template is loading the first 10 posts of the category and paging the next 10 posts (even though only 3 are shown).

    Any ideas?

  27. creativeworldstudio
    Member
    Posted 5 years ago #

    I'm having major issues as well and would appreciate any help/idea's you might have. (Running WP2.5.1)

    custom front page:
    http://www.creativeworld.com.au
    blog located:
    http://www.creativeworld.com.au/blog

    Permalink structure: (custom)
    /blog/%category%/%postname%/

    Category base: (method to use /blog/%category%/ as instead of /blog/category/%category%/)
    /blog/.

    .htaccess file:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    findings so far:
    - changing permalink structure to default or changing to a different custom structure (ie- /posts/%category%/%postname%/) makes /page/2 previous entries work (but this is not a solution!)

    There seems to be a conflict between category base and permalink structure...??

    Please please please help!!

  28. creativeworldstudio
    Member
    Posted 5 years ago #

    Update:

    After more thinking of what could be the cause, I remembered that my blog is uses a static front page called (Home) and the static page to view posts is called "Blog"...

    Could it be that when a user clicks on previous entries, wordpress is looking for a static page at mydomain.com/blog/page/2 - which does not exist (hence the 404) ???

    If I change the name of the static page for posts, then everything works fine.. however I need to have my blog posts located at mydomain.com/blog/

    Any ideas on a solution/fix?

  29. creativeworldstudio
    Member
    Posted 5 years ago #

    Another Update:

    I found this issue being tracked (ticket #6603) - This bug looks to be a serious issue. (bad next_posts_link when using a Static Front Page and custom permalink structure.)

    I wish it had been addressed in 2.6 :(
    Again, if anyone has a hot fix/solution I would love to hear from you.

    Cheers.

  30. poptaste
    Member
    Posted 5 years ago #

    i got a same problem...next page is always 404 if i change the permalink to a custom permalink...but it's normal again when i changed it to default permalink...i've tried this on wp 2.6 and still got a same problem

    i got another WP blog hosted with the same hosting but it works fine even after i change to custom permalink. :(

Topic Closed

This topic has been closed to new replies.

About this Topic