WordPress.org

Ready to get started?Download WordPress

Forums

SlickQuiz
[resolved] Preview issues on subdirectory installation (7 posts)

  1. bobbrown99
    Member
    Posted 1 year ago #

    Hi,

    I just installed SlickQuiz and everything's working fine except for one thing - I can't preview any quizzes.

    The preview box comes up and everything, but my WP installation is on a subdirectory (http://fra1.net/news). When I click the 'preview' button on a new quiz page, the pop up URL is:

    http://fra1.net/previews/wp-admin/admin.php?page=slickquiz-edit&id=2&id=8

    And the URL in the main window that it tries to go to is:

    http://fra1.net/edits/wp-admin/admin.php?page=slickquiz-edit&id=2&id=8

    Note that in both instances the '/news' part of the URL is missing and neither of them work (get 404 for both).

    Thanks

    http://wordpress.org/extend/plugins/slickquiz/

  2. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @bobbrown99 - Hmmm.. that is very strange. It shouldn't even be adding the /previews/ and /edits/ to the URLs.

    Can you tell me what version of WordPress you're using?

  3. bobbrown99
    Member
    Posted 1 year ago #

    I'm using 3.4.2

  4. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @bobbrown99 - Do you have any plugins that might be altering the URL structure? Or any other customizations that might be interfering?

    I'm really not sure where the problem might be, as I've tested the plugin on sub domains and everything has worked fine. I'm completely stumped as to where those /previews/ and /edits/ are coming from...

  5. bobbrown99
    Member
    Posted 1 year ago #

    Well this is my .htaccess file: http://pastebin.com/ZtfHYVrw and it doesn't look like there's anything in there that could be causing this.

    I do have a number of plugins, but none of them alter the URL structure at all (except for a security plugin, but I deactivated that and it made no difference).

    Something even stranger that I just found out. When I click 'preview' from the /wp-admin/admin.php?page=slickquiz page (not on the quiz page itself), the preview works fine in the pop-up window, but I can't publish from there. There is only a 'reload' and 'close' button.

  6. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @bobbrown99 - Thanks for providing me with all these details. I was able to find the problem and have just pushed out a bug fix for the issue!

    Look for version 1.0.19 to be available any minute now. If you still have the problem, let me know!

  7. bobbrown99
    Member
    Posted 1 year ago #

    Wooo yes it's working now. Thank you very much :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic