WordPress.org

Ready to get started?Download WordPress

Forums

Markdown on Save Improved
[resolved] Preview is markdown text, not the converted html (13 posts)

  1. jackysee
    Member
    Posted 1 year ago #

    Hi, I've installed the plugin and try to write a new post in markdown. But when I preview the post, the output is the raw markdown, not the converted html.

    http://wordpress.org/extend/plugins/markdown-on-save-improved/

  2. jackysee
    Member
    Posted 1 year ago #

    When the post is saved and published, the rendering is correct html.

  3. jackysee
    Member
    Posted 1 year ago #

    I found that the preview will not render markdown to html when the post is in published state. i.e. when I re-edit an old post and preview.

  4. navarroj
    Member
    Posted 1 year ago #

    Are there any plans to fix this? Other than this (big) annoyance, Markdown on Save improved is the best plugin for my needs!

  5. Matt Wiebe
    Member
    Plugin Author

    Posted 1 year ago #

    navarroj: it works fine for me. WP version, MoSI version?

    It's most likely a plugin conflict.

  6. jackysee
    Member
    Posted 1 year ago #

    wordpress 3.5.2
    MoSI 2.4.2

  7. navarroj
    Member
    Posted 1 year ago #

    Same here: wordpress 3.5.2, MoSI 2.4.2

  8. Matt Wiebe
    Member
    Plugin Author

    Posted 1 year ago #

    In any testing I do with both of those versions, previews show converted Markdown (as they should).

    Maybe try deactivating all your other plugins and/or a different browser?

  9. navarroj
    Member
    Posted 1 year ago #

    I think I've found the cause of the bug. I tried disabling all plugins (except for “Options Framework” which, for some reason, seems impossible to disable).

    If you try to edit and preview an already published post, then "preview changes" shows the markdown instead of the converted HTML, but for a new post (or even just changing the status of an already published post back to "draft") then "preview" will do the correct thing, interpret and render the Markdown as expected.

    I've tried this both on Chrome and Safari with exactly the same results, so I guess the browser doesn't have much to do with it.

  10. Chris Van Patten
    Member
    Posted 8 months ago #

    I'm encountering the same problem. Preview works fine, until a post is scheduled or published. After that, the preview breaks.

  11. Matt Wiebe
    Member
    Plugin Author

    Posted 8 months ago #

    navarroj, thanks for finding where the bug was happening, and apologies for taking a long time. This is fixed in MoSI 2.4.4, which is now live.

  12. Matlab Recipes
    Member
    Posted 6 months ago #

    I think I have(had?) the same problem, and as a work around selected the option "Disable Markdown formatting" which seemed to help.

    However, I have a problem where my subscriber emails contain a preview with Markdown. Does selecting the option above cause the main article to be stored in markdown?

    Now the problem is fixed (I think I may have only ever used 2.4.4 as I only started blogging mid December) if I deselect that option will everything sort itself out and I'll get html in the database & emails?

  13. Matlab Recipes
    Member
    Posted 6 months ago #

    I've just tried deselecting the option. i.e. Enabling markdown formatting on one of my posts:
    http://matlabrecipes.com/matlab-linear-indices/

    All is well, except the code blocks. They have spurious <p>s. So is there an incompatibility between this plugin and SyntaxHighlighter Evolved?

    I'm also using: Typewriter - Markdown for WordPress
    would that cause any issues?

    Thanks for any help. I can start a new thread if you prefer.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic