WordPress.org

Ready to get started?Download WordPress

Forums

Preview before publish does not work in 2.7 (14 posts)

  1. simensen
    Member
    Posted 5 years ago #

    I upgraded to WordPress 2.7 a few days ago and I've noticed that the Preview button seems to work only part of the time. After further testing, I've discovered that the Preview button DOES work, but only after the post is published.

    If I click "Preview" prior to the post being published, it sends me to:

    http://not-invented-here.com/?p=100&preview=true

    However, that does nothing except show me the front page.

    I have tested this with the default theme (WordPress Default) and it behaves in the same way.

  2. milo2man
    Member
    Posted 5 years ago #

    I have the same problem running 2.6.1.

    WordPress address is http://www.example.com/wp/

    Blog URL set to http://www.example.com/

    Preview link is http://www.example.com/?p=nn&preview=true takes me to the main page of the site (not the blog page).

    Previews used to work fine before I moved the blog URL out of the wp directory.

    I created a page in wp called "blog" and have my loop on that page. This I link to from the sites main page with http://www.example.com/blog/

    The site's main page is http://www.example.com/index.php which just shows the latest post exerpt and other static content.

    Everything works fine except for the post preview. Anyone have any ideas.

  3. bucks14
    Member
    Posted 5 years ago #

    I have the same problem as milo2man.

    Previews in 2.7 had worked fine for me until today. Changed my blog to work in the root directory (Blog URL set to http://www.example.com/). Created "Home" and "Blog" pages and set the static Front Page to Home, the Posts Page to Blog. Permalinks updated with new structure. Now the previews are "Not Found".

    Any experts out there?

  4. kirkryyn
    Member
    Posted 5 years ago #

    Really? Nobody? This is super annoying. Please help!

  5. Dion Hulse
    WordPress Dev
    Posted 5 years ago #

    Sounds like it could possibly be caused by a plugin or theme to me.. Try disabling your plugins and reverting to the Default theme.. See if it works then..

  6. Roy
    Member
    Posted 5 years ago #

    I have no problems with the preview, not for published post, not for unpublished posts. DD has a good suggestion, perhaps it's a plugin.

  7. finestimaginary
    Member
    Posted 5 years ago #

    I have this problem with 2.7, along with many others. If you save it as a draft and then preview, it seems to work.

  8. Kourosh
    Member
    Posted 5 years ago #

    I was having difficulties even when saving as a draft.

    But, I think things are now fixed: In the general settings I remember I had removed the "www." from the blog address. Returning it to its original status (i.e. http://www.blogaddress.com/) fixed the problem. I'd prefer not to have the www, but the preview capability is more important. Hope this helps for others.

  9. milo2man
    Member
    Posted 5 years ago #

    I found a workaround that might help the rest of you.

    First, I save a draft of a new post and mentally note its title slug. I then manually insert the title into the preview URL path.

    Let's say I write a post called "New Post". The Permalink on my site would be:
    http://www.example.com/new-post/

    WP generates the following URL for the preview:

    http://www.example.com/?p=123&preview=true

    This returns me to my homepage. However, if I insert the post title slug into the path, for example:

    http://www.example.com/new-post/?p=123&preview=true

    Then I get the preview!

    I assume that the problem has something to do with the way my .htaccess file uses rewrite rules, but it's beyond my ability to figure it out. Anyone have any ideas?

  10. AlexinMilan
    Member
    Posted 5 years ago #

    Hi,

    I was having this annoying preview problem. I've solved it though.

    I went to Settings>General, and changed the WordPress address (URL)
    and Blog address (URL) to both use www. Saved the new settings, was logged out of WP, logged in, and Hey Presto, I can now preview my posts.

    I'm running the latest version of WP.

    Hope that helps.

    Best,

    Alex

  11. johnwar
    Member
    Posted 5 years ago #

    I had the same problem with IE6, but it's fine with FF.

  12. rcpkrc
    Member
    Posted 5 years ago #

    yep, ff doesnt giwing any problem.

  13. dwcouch
    Member
    Posted 4 years ago #


  14. dwcouch
    Member
    Posted 4 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic