WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Preventing Change in Portfolio Background Color on Blox Theme (8 posts)

  1. rodrigopestana
    Member
    Posted 8 months ago #

    Hello!

    On my Home Page, the background colour set for the latest portfolio created does not show: everything else is right but it still shows the default colour. When I add a new portfolio, the previous one starts showing the right colour automatically.

    This happens only on my first language (PT), not on the second one (EN).

    When I deactivate Polylang, both PT and EN portfolios show on the (same) Home Page in the correct colour.

    Can you help?

    Thank you,
    Rodrigo

    Website: latinroom.org
    Theme: Blox by Themezilla
    Permalinks: Custom (/year/postname/ for PT and /en/year/postname/ for EN)
    Front Page: Static
    Polylang Setting
    - Redirection according to browser preferences
    - Language code /en/ is on for second language only
    - /language/ is off
    - Custom Post Types: Portfolios

    http://wordpress.org/plugins/polylang/

  2. rodrigopestana
    Member
    Posted 7 months ago #

    I've just updated Polylang and now the problem happens on the second language (EN) instead...

    Can someone give me a hint on this, please?

    Thanks.

  3. Chouby
    Member
    Plugin Author

    Posted 7 months ago #

    I am sorry but I can't help with a theme which is not freely downloadable. However I will be glad to cooperate with the theme author if he wants to.

  4. rodrigopestana
    Member
    Posted 7 months ago #

    Thanks!

    Already shared your availability to cooperate with the theme developers. Looking forward to their feedback.

    All the best,
    RP

  5. marksouthard
    Member
    Posted 7 months ago #

    Hello, I'm one of the devs on the Blox theme. We create a dynamic stylesheet on the fly. Within that file creation, we're hitting an error with the polylang error:

    <b>Warning</b>: in_array() expects parameter 2 to be array, null given in <b>/home/blackmam/public_html/latinroom.org/wp-content/plugins/polylang/include/auto-translate.php</b> on line <b>16</b><br />

  6. Chouby
    Member
    Plugin Author

    Posted 7 months ago #

    Hello! I am glad you accepted my offer to cooperate. Could you please use the latest v1.2.3? This error should be removed since v1.2.

    If you believe that the "auto translate" feature can conflict with your theme, you can disable it by setting PLL_AUTO_TRANSLATE to false in wp-config.php

  7. rodrigopestana
    Member
    Posted 7 months ago #

    Thanks for your cooperation!

    Unfortunately, the upgrade to 1.2.3 apparently aggravated the problem:

    Now it's the english home page that's showing the default portfolio color, but on all the portfolios (instead of just on the latest one).

    I added define('PLL_AUTO_TRANSLATE', false); to the wp-config file as suggested but nothing seems to have changed.

  8. rodrigopestana
    Member
    Posted 7 months ago #

    Hi!

    Looking forward to you input on this matter.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic