WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] Prevent Event Handler (4 posts)

  1. geologist
    Member
    Posted 1 year ago #

    I have three slideshows side by side. They scroll horizontally so it looks as though one image slides into the next location to the left of it. Please see what I am referring to

    Ten Mile Run Test Website

    The concept works great . . . until I touch one of the slideshows with my mouse or scroll the page etc. Is there some way in the JS file to disable event handler or something like that to get the slideshows to ignore any touches or scrolling on the page?

    I realize this will probably disable touch for handheld devices, but that is not a concern.

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    You can disable the touch navigation by using a custom slideshow script and removing this bit if code:

    // Setup jQuery TouchWipe
    $j('.meteor-slides').touchwipe({
        wipeLeft: function() {
            $j('.meteor-slides').cycle('next');
        },
        wipeRight: function() {
            $j('.meteor-slides').cycle('prev');
        },
    	preventDefaultEvents: false
    });

    The other thing you will want to do is disable the pause on hover so that doesn't throw off your animation, you can do this using metadata, here's an example:

    [meteor_slideshow metadata="pause: 0"]
  3. geologist
    Member
    Posted 1 year ago #

    Thanks Josh, that did it. Your website is packed with lots of great info.

  4. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic