WordPress.org

Ready to get started?Download WordPress

Forums

Pretty URLs don't work (6 posts)

  1. Luke23
    Member
    Posted 8 years ago #

    Hi,
    I tried to set the Permalink Structure to "/%category%/" via the options, saved it, he told me "Permalink structure updated." - no errors - but the permalinks just don't work. There isn't even a .htaccess file. I'm running WP locally on a windowsmachine so it can't be the permissions.

    Thanks in advance,
    Luke

  2. gMk
    Member
    Posted 8 years ago #

    You sure the htaccess isn't hidden ?
    I think i am correct in saying you need the htaccess file for permalinks to work. Change you ftp software to show hidden files and make it htaccess writable [ 666] and update the permalinks again. Then set the htaccess file back to 644

  3. Luke23
    Member
    Posted 8 years ago #

    I'm using WP locally on windows so I don't need FTP. There is no hidden .htaccess. There is no .htaccess at all. I tried to create an empty .htaccess so WP can write into it - but it stays empty. Still WP doesn't provide any errormessages.

  4. Luke23
    Member
    Posted 8 years ago #

    PathInfo-Pretty-URLs ( http://localhost/WP/index.php/category ) do work btw, but WP generates links pointing to a 'real' pretty URL

  5. Chris_K
    Member
    Posted 8 years ago #

    I tried to set the Permalink Structure to "/%category%/"

    Why would you do that?

    That would attempt to give every post in a category the exact same url. Unless there's more to this, I can't for the life of me see how that would work as a post permalink URL.

    Suppose you went to your Permalink page and checked the "Date and name based" option. Does that work?

  6. moshu
    Member
    Posted 8 years ago #

    Just to confirm what HandySolo said: ONLY with "category" it won't work.
    Furthermore re: Windows:
    http://codex.wordpress.org/Using_Permalinks#Using_Permalinks_Without_mod_rewrite

Topic Closed

This topic has been closed to new replies.

About this Topic