WordPress.org

Ready to get started?Download WordPress

Forums

Pretty URLS (17 posts)

  1. 0n35
    Member
    Posted 2 years ago #

    I just can't get them to work, I give the folder 777 permission, and it no longer displays the message saying that it would make my .htaccess file if it had access, but when I click on the links I'm still getting a 404, what is the problem? I looked in my database and it seems like the pages are there.

  2. Ask your host if mod_rewrite is enabled for your web server and your directory.

  3. 0n35
    Member
    Posted 2 years ago #

    It is.

  4. Mandrake7062
    Member
    Posted 2 years ago #

    I have this same exact problem and mod_rewrite work fine.
    I have the hotfix .8 enabled and the WCS Custom Permalinks Hotfix

    And that is all. I have the Twenty Ten 1.3 theme running on Apache server.

  5. It may be active but not enabled for your directory.

    Check if Allowoverride All is set in your Apache configuration.

    <Directory />
      Allowoverride All
    </Directory>
  6. 0n35
    Member
    Posted 2 years ago #

    Did what you said, didn't change anything, although in that I also have:
    Options FollowSymLinks, would that be the matter?

  7. Mandrake7062
    Member
    Posted 2 years ago #

    So I need to talk to my host provider?

  8. 0n35
    Member
    Posted 2 years ago #

    @mandrake I'm pretty sure you can do the same thing with a .htaccess file

  9. I'm pretty sure you can do the same thing with a .htaccess file

    I believe that's right but I've never gotten it to work there myself. I mean, if the Allowoverride All could work in .htaccess then you probably wouldn't need to override anything...

    Check with your host provider and see what they say.

  10. Mandrake7062
    Member
    Posted 2 years ago #

    Thanks guys, I'll check with my host.

    If I create an .htaccess file and ftp it up.
    It has no rights so I put all rights in.
    Go back to the page and hit update.
    Still won't work.
    I know the file is hidden I guess but if I go back later and ftp another one, it does not ask me if I want to overwrite.
    I mean it should ask me that even if it were hidden right? It's like it just disappears..

  11. 0n35
    Member
    Posted 2 years ago #

    You should be able to click view hidden files on your site.

    But anyways, this still isn't working, in my httpd.conf I changed
    Options FollowSymLinks
    to
    Options +FollowSymLinks

  12. 0n35
    Member
    Posted 2 years ago #

    :\

  13. Mandrake7062
    Member
    Posted 2 years ago #

    I had my host make the adjustment but it still doesn't work.

    I'll have to shelve this until I can get down there and talk to him face to face and see what he did.

  14. 0n35
    Member
    Posted 2 years ago #

    Sometime this next week i hope someone has the answer

  15. ClaytonJames
    Member
    Posted 2 years ago #

    Sometime this next week i hope someone has the answer

    Instructions on how to configure your server is not really what the forum is for, but that being said, it's a nice bonus that you can usually easily find some of that information here.

    I guess you must have complete control of the server if you're playing with httpd.conf, so I'll take a guess at it. You can try this if you like;

    /httpd.conf

    # First, we configure the "default" to be a very restrictive set of
    # features.
    #
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>

    Then -

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
        AllowOverride All

    - restart httpd after saving the changes. Assuming mod_rewrite is working correctly, pretty permalinks should work fine now.

    If you're working on a ubuntu server that uses symlinks for virtual host configuration, you should only need to navigate to sites-enabled-default and place the 'AllowOverride All' directive in the virtual host configuration file and restart apache to get permalinks working. Those are pretty general instructions, but I think that should make things work.

  16. 0n35
    Member
    Posted 2 years ago #

    Thank you soooooooo much, it's working perfectly now!

  17. ClaytonJames
    Member
    Posted 2 years ago #

    You're welcome, I'm glad it helped.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.