WordPress.org

Ready to get started?Download WordPress

Forums

Pretty permalinks only show homepage (7 posts)

  1. katootje
    Member
    Posted 5 years ago #

    Hi, on a site I want to use the permalink option /%postname%/ When I do that, the url is fine but in the site only the homepage is shown. I looked in the forum and found this thread:
    http://wordpress.org/support/topic/140516?replies=7 , the past post had the same problem, but the topic is closed and i find no clue how it is solved. Everything is working fine with the standard ones with the ?, but none of the other options is working. htaccess is good, als far as I can see, the title and the paga stays the same. The url is changing. Where can i look. ALl the other threads with permalinkproblems has the 404, I cleared that one, but now only the right page in view.

    Thanks

  2. Hiranthi
    Member
    Posted 5 years ago #

    Well, you should use something similar to /%category%/%postname%/
    If you'd set the permalink structure to something like /%category%/%postname%.html you'll notice that only the posts will have the %postname%.html part in the url. Pages don't use that part of the permalink structure and my guess is that that's why you've been getting the 404's.

  3. Samuel B
    moderator
    Posted 5 years ago #

    @ katootje - review this
    http://codex.wordpress.org/Using_Permalinks#Using_only_.25postname.25

    @ illutic - category 1st is not so great
    from codex

    For performance reasons, it is not a good idea to start your permalink structure with the category, tag, author, or postname fields. The reason is that these are text fields, and using them at the beginning of your permalink structure it takes more time for WordPress to distinguish your Post URLs from Page URLs (which always use the text "page slug" as the URL), and to compensate, WordPress stores a lot of extra information in its database (so much that sites with lots of Pages have experienced difficulties). So, it is best to start your permalink structure with a numeric field, such as the year or post ID.

  4. Hiranthi
    Member
    Posted 5 years ago #

    Well, to be quite honest, I don't want to use the year or id of the post/page in the permalink. Especially not in the beginning of it (that's why I always use the one I mentioned before).
    But hey, that's just my opinion. Thanks for mentioning it though :)

  5. mattcav
    Member
    Posted 5 years ago #

    same problem: customizing my theme, all links, with one of permalink mode on, don't works. the url changes, but not the page displayed -always homepage. all ok with no permalink (example.com/?p=2). i've asked for it at my hosting support ((dreamhost) and they said that's it's all right with apache (httpd.conf) and i've checked .htaccess

    any ideas to solve? i'm considering to reinstall wordpress (running 2.8), but i don't know if this is a good solution.

  6. iridiax
    Member
    Posted 5 years ago #

    See: http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks

    If your theme does not have a 404.php, then the home page will be loaded instead for a 404 Not Found, which is what you get if pretty permalinks are not working.

  7. mattcav
    Member
    Posted 5 years ago #

    that's the strange: my theme has a 404.php, and it's working well if you make a request by searchform.

    as i said, i've re uploaded /wp-admin and /wp-includes overwriting all.
    turn on classic wp theme, disabled all plugin, and worked fine.

    then i've load my custom theme, and i've reinstalled all plugin one by one, loading homepage for each one.

    all ok, exept this one: WP .htaccess Control. when i've reactivate it, and rebuild his rule for rename /author/ URL, it brokes all.

    re-uploading /wp-admin (but just for to be sure) and /wp-includes, activate theme and all plugin except this one, and now all works very well.

    i'm writing to plugin developer to know more...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags