WordPress.org

Ready to get started?Download WordPress

Forums

Pretty permalinks not working for sub-directory WordPress site (4 posts)

  1. thfump
    Member
    Posted 2 years ago #

    Alright... I've searched the forums, the codex and the web for hours now and tried a good bit of old fashioned trial-and-error. And I still haven't figured this one out. Thanks in advance for your assistance.

    Here's my set-up:
    I just installed WordPress 3.3.1 on a new GreenGeeks-hosted account, inside a subdirectory at freeish.net/msp/.

    Here's what I think one of the big issues is:
    Wordpress somehow thinks that it's installed at the root level, not within /msp/. This is evidenced by the fact that the /wp-admin/options-permalink.php page shows its example permalinks like this:

    Default http://freeish.net/?p=123
    Day and name http://freeish.net/2012/04/09/sample-post/
    Month and name http://freeish.net/2012/04/sample-post/
    Numeric http://freeish.net/archives/123
    Post name http://freeish.net/sample-post/

    This isn't at all what I want either. What I'm looking for is: http://freeish.net/msp/sample-post/.

    Here's what happens in various situations:

    1) When permalinks are set to "Default":
    The front page at freeish.net/msp/ shows up correctly, but internal links to posts or pages are created at the root level of the domain (e.g., freeish.net/?p=34) and simply redirect to the index at freeish.net, not to any WordPress page at all.

    2) When permalinks are set to "Post Name," as I would like them to be:
    The front page at freeish.net/msp/ shows up incorrectly, with a "Not Found" error where the first post should be. All links to posts and pages (e.g. on the "Post Archive" calendar) lead to 404 errors.

    3) (How the site is currently set up.) When permalinks are set to "Post Name," and I manually add "/msp/" in two places in the .htaccess file, according to Perishable Press' "Htaccess Rules":
    The front page at freeish.net/msp/ shows up incorrectly, as in #2 above. Internal links to posts are still created at the root level (e.g., http://freeish.net/under-construction-update-9-april-2012/ or http://freeish.net/contact/), but these "pretty permalinks" do work, as you'll see if you click on them.

    One more note:
    I've tried using the "Custom Structure" option on the /wp-admin/ permalink settings page to force the structure to be "/msp/%postname%/" -- but this just results in the same 404 errors as attempt #2 above. Ugh.

    So to summarize, all I want to do is:
    1) make the freeish.net/msp homepage display posts as it should, and
    2) make the permalinks appear at http://freeish.net/msp/sample-post/.

    Help?! (Thanks!)

  2. thfump
    Member
    Posted 2 years ago #

    Well, it's been 24 hours now, and no responses. :/ I'm still frantically pulling my hair out about it, and none of my messing w/ .htaccess is doing any good. Any ideas anyone?

    Thanks much.

  3. pamajoro
    Member
    Posted 2 years ago #

    Hi,

    Just wondering if you've figured this out yet. I'm having the same problem and can't figure it out for the life of me.

    If you have, can you please post your solution?

    Thanks.

  4. Eyal Azulay
    Member
    Posted 2 years ago #

    Hi
    I just encountered the same problem with a site that worked before. So my guess is that something changed in the upgrade to WP 3.4.1.

    Every link to a page in the subfolder was redirected to the same page in the root. so I figured it must be related to the Permalink setting. The Permalink was set to "Post name" and the example showed a correct URL (i.e. including the subfolder). So I tried changing it to a Custom Structure using the same idea, and it worked!
    In my case the subfolder name is "p" so I changed it to: /p/%postname%/
    So in your case it would be: /msp/%postname%/

    I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic