WordPress.org

Ready to get started?Download WordPress

Forums

pretty permalinks losing style.css (mod_rewrite enabled and AllowOverride on) (1 post)

  1. friesenj
    Member
    Posted 7 years ago #

    The blog and permalinks I set up is working fine until I try to customize them. I made sure mod_rewrite is enabled, AllowOverride is set to All, and WordPress updates my my .htaccess file as:

    -------------------------
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # END WordPress
    -------------------------

    when I set the custom permalinks as date and name based. The links are being rewritten with a date and name, and when I click on them, they "work" in the sense that I am taken to a page with the new, nicely formatted link, but it won't load the css file. I feel like there is a simple solution, but I looked all over the support forums and couldn't find it, and I can't figure it out. Any suggestions would be greatly appreciated. thanks

    the blog is at:
    http://www.kylemills.com/blog/index.php

    the phpinfo.php file is at:
    http://kylemills.com/phpinfo.php
    In case that would help anyone. I am not 100% sure that mod_rewrite is enabled, but the phpinfo.php file says that that module is loaded (does that mean enabled?) and the permalinks are getting rewritten...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.