WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pretty Permalinks create 404 errors & no New Posts appear (6 posts)

  1. amprescott
    Member
    Posted 1 year ago #

    Several months ago, pretty permalinks stopped working on my blog. After some research, it sounded like Windows hosting was my problem, so I switched from Godaddy/Windows to Hostgator/Linux. I updated the permalinks format last night, but unfortunately it seems like I'm dealing with a much bigger problem.

    When "default" permalinks are switched on, old post links are accessible and seem to work fine. When I switch to "pretty," (even with an updated .htaccess file), none of the old posts that were created with pretty permalinks work; I get nothing but 404 errors. I also can't seem to create any NEW test posts that will open, no matter if I create them with default permalinks or pretty ones. In other words, nothing new is posting to the blog, no matter what the permalinks are set to.

    Could this be something to do with moving from GoDaddy/Windows to HostGator/Linux? I am completely baffled. Thanks in advance for any help!

    Blog address is: raisingcamelot.com

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Could this be something to do with moving from GoDaddy/Windows to HostGator/Linux?

    Scanning tools show that you are still using Windows hosting provided by GoDaddy. Is your GoDaddy site still live?

  3. amprescott
    Member
    Posted 1 year ago #

    Yes, I guess it is. Hosting plan doesn't expire for a little bit longer.

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Your site is still being loaded from GoDaddy, not from your new host, right? If so, the same problems might continue, and troubleshooting may not be worthwhile at this stage, I think. Also, tell us if you have moved your site to the new host and your new URL there.

  5. amprescott
    Member
    Posted 1 year ago #

    Eureka! Deleted the folder at the old host and updated the DNS. Now pretty permalinks work and I can post.

    Thank you, Krishna! Hopefully that's my only "duh" moment this week...

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Glad to know that you could resolve it! :)

Topic Closed

This topic has been closed to new replies.

About this Topic