WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pretty Permalinks (25 posts)

  1. chanel
    Member
    Posted 5 years ago #

    I've searched high and low for a resolution to this and people keep referring others to Using Permalinks, when the answer is not there.

    I would like to know how to do this:
    http://mydomain.com/my-blog-post

    instead of this:

    http://mydomain.com/index.php/my-blog-post

    (Notice the difference is the "index.php" is in the middle)

    Again, "Using Permalinks" page doesn't tell you how & I have Googled this many times. Is it fair to say that it cannot be done at all?

  2. stvwlf
    Member
    Posted 5 years ago #

    When hosted on Linux, WordPress defaults to http://mydomain.com/my-blog-post

    1) Are you hosted on Linux?

    2) Try asking your webhost tech support

  3. chanel
    Member
    Posted 5 years ago #

    Yes, my domain is hosted on a Linux webserver & that doesn't solve the issue.

  4. chanel
    Member
    Posted 5 years ago #

    anyone?

  5. chanel
    Member
    Posted 5 years ago #

    .

  6. ogonkov
    Member
    Posted 5 years ago #

    Very strange, i don't have such things. What is into you permalinks settings?

  7. chanel
    Member
    Posted 5 years ago #

    bump.

  8. chanel
    Member
    Posted 5 years ago #

    bump #2

  9. Roy
    Member
    Posted 5 years ago #

    Chanel, what do you have for permalink? Just %postname% (not too smart)? Normally, "index.php" only appears when you put it there yourself, but maybe this is the reason that people asked what your serversoftware is. I don't know anything about that, but when you don't have "index.php" in your permalink yourself, talk to your host.

  10. chanel
    Member
    Posted 5 years ago #

    I have /index.php/%postname%/ because when I put /%postname%/, it gives me an error on my site.

    So I need to contact my host and say what? They seldom give wordpress tech support so i want to know what it is i need to ask/tell them to have this edited for me.

    Thanks gangleri.

  11. Roy
    Member
    Posted 5 years ago #

    Did you read my "not too smart" link??
    Use %post_id%/%postname% or something.

  12. chanel
    Member
    Posted 5 years ago #

    And did you read my original post?

    I said I do not want anything else there BUT postname.

    I do not want post id.
    I do not want category.
    I do not want the date.
    I do not want index.php.

    I want my links to look like http://mydomain.com/POSTNAME

  13. Roy
    Member
    Posted 5 years ago #

    It's not possible, WP breaks as you noticed.

  14. iridiax
    Member
    Posted 5 years ago #

    As Using Permalinks explains, permalinks with index.php in them are PATHINFO permalinks, and they are what you can use if you don't have mod_rewrite.

  15. chanel
    Member
    Posted 5 years ago #

    Some people eliminate some or all of the date elements (day, month, year) to have a shorter permalink format. Note: mod_rewrite permalinks require Apache's mod_rewrite module.

    How can I do that? I know nothing about mod_rewrite nor Apache. I know it is possible to achieve this because I have seen blogs that use wordpress with their links like the way i am seeking.

    Also please refer AGAIN to my original post:

    I've searched high and low for a resolution to this and people keep referring others to Using Permalinks, when the answer is not there.

    Sidenote: My frustration is with responders who just redirect you to something on wordpress codex that you've already thoroughly read thru. If you're unable to assist, just do not reply.

  16. Roy
    Member
    Posted 5 years ago #

    First, I can't tell what you've already read, you might have missed something.
    Second, you're asking for something impossible on server configuration. Sure, some people have managed to do that, my guess is that their server works differently, they use other software (or an entirely different server alltogether). Just take it that what you want is not going to work unless you can work something out with your host, but I have no idea what. The codex doesn't say what it says without good reason.
    And as a sidenote: telling you that what you want is not possible is also assistance!
    Sincerely,
    Roy

  17. chanel
    Member
    Posted 5 years ago #

    Bottom line is, if "some people managed to do it", that means it can be done.

    Anyways, to others that may bump into this topic, if you're able to give me positive direction towards this, that does not include a redirection to that USING PERMALINKS link, I would greatly appreciate it.

    I'll contact my host and see what they say as well. If I receive any better advice from them to this, I'll update this post which such.

  18. chanel
    Member
    Posted 5 years ago #

    I contacted my host and they were able to achieve this for me. What they did was add a mod_rewrite rule to my .htaccess as follows:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Then I went back to the Permalinks option in my wp-admin and changed it to /%postname%/

    The "impossible" was done.
    (:

  19. Doodlebee
    Member
    Posted 5 years ago #

    For the record, the "Using Permalinks" in the codex *does*, indeed, provide the answer for you.

    In regards to someone above (the "not too smart" link), using simply "%postname%" isn't always a great idea, but you are certainly welcome to so it as long as you're careful.

    The answer you were seeking, though *was* (and still is) on the codex page you'd been referred to a few times.

    and I quote:

    Using "Pretty" permalinks
    
    Requirements:
    
        * Apache web server with the mod_rewrite module installed
        * In WordPress's home directory,
              o The FollowSymLinks option enabled
              o FileInfo directives allowed (e.g. AllowOverride FileInfo, AllowOverride All)
              o An .htaccess file (if this file is missing, WordPress will try to create it when you activate "pretty" permalinks)
              o If you want WordPress to update the .htaccess file automatically, WordPress will need write access to the file.

    Since your host set it up for you, I would guess that you did not have an .htaccess file on your server. But the instructions above do state that you *must* have the .htaccess file there. WordPress *will try* to create one - but different servers have different permissions, and it's not a guarantee that it *will* be created.

    Glad you got it sorted - but just setting the record straight that the info was (and still is) right there in the codex.

  20. DiDe
    Member
    Posted 5 years ago #

    Hi, I have been having this same issue for some time. Still haven't managed to get it working right.

    I have already posted this here on this forum , but the post has gone cold..

    I have contacted my host and this was there response.

    >>>>>>>>>>>>>>>> Quote <<<<<<<<<<<<<<<<<
    Mod-rewrite is enabled. However, we utilize php-suexec, i believe that requires a slight mod with the wordpress code. You can post this additional info, and I am sure someone will pop in with the correct answer, if not let me know.

    >>>>>>>>>>>>>>>> End Quote <<<<<<<<<<<<<<<<<

    As much as I would like to have a pretty permalink using just the %postname% like Chanel. I hear everyone's warnings not to do so, not that I have a clue of the consequences. But must be for good reason..

    I just would like to see the 'index' part disappear, and be left with only /%post_id%/%postname%/

    A little note here, in regards to Chanels comment:

    Sidenote: My frustration is with responders who just redirect you to something on wordpress codex that you've already thoroughly read thru. If you're unable to assist, just do not reply.

    I will appreciate all advice, whether it gives the final outcome I am after or not. The fact that you are willing to assist me is always graciously appreciated. For that I thank you in advance.

  21. DiDe
    Member
    Posted 5 years ago #

    Is this post no long active

  22. robert.b.bruce
    Member
    Posted 5 years ago #

    I have just installed WordPress 2.8 on a smartyhost linux server. When I run an info.php file, it says that the mod_rewrite module is installed. I have also uploaded a .htaccess file in the root directory with the following:

    ># BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress<

    When I enable permalinks (numbers) I cannot access the posts at all. It also appears that wordpress hasn't changed the .htaccess file even though the permissions are set to do so. Help! What else can be done?
    Also the codex offers the following suggestions:

    * In WordPress's home directory,
    o The FollowSymLinks option enabled
    o FileInfo directives allowed (e.g. AllowOverride FileInfo, AllowOverride All)

    What does this mean to us uneducated? Any smart cookie that could help would be greatly appreciated....

  23. buntz
    Member
    Posted 5 years ago #

    robert I too am on smartyhost and am having the EXACT SAME PROBLEM. I have uploaded same code in .htaccess file. Although it says update successful when I change permalinks in the WP control panel, nothing actually works!

  24. Dr C
    Member
    Posted 5 years ago #

    I too have the exactly the same problem. Also, adding either
    Options FollowSymLinks

    or

    Options FollowSymLinks+

    hasn't helped as was suggested here

    I note that this topic is marked [resolved] does that mean we should start a new one to get this problem sorted? Thanks for the help.

  25. Dr C
    Member
    Posted 5 years ago #

    Ok, I got it working for me with the help of some excellent websites and tech support.

    My host was running Zeus not Apache, so the server needs a file rewrite.script to do the task of .htaccess. The contents are given in several websites, but here's one.

    Hope that helps somebody.

Topic Closed

This topic has been closed to new replies.

About this Topic