WordPress.org

Ready to get started?Download WordPress

Forums

Pretty permalink not working (6 posts)

  1. kurai
    Member
    Posted 6 years ago #

    Hi there.
    It seems I can't get permalink work on a blog I''m building.
    Standard permalinks do work, but when I switch to pretty, it gives me this error:

    Not Found

    The requested URL /2007/07/13/hello-world/ was not found on this server.

    Apache/2.2.3 (CentOS) Server at marcobertolotto.provincia.savona.it Port 80

    Some notes:
    - Mod-rewrite is enabled
    - .htaccess has full access permissions
    - I tried to change vars.php according to the codex, but without success.

    What should I do?

  2. MyklK
    Member
    Posted 6 years ago #

    I'm facing the exact same problem. Regular RSS works, pretty doesn't. Have Mod_rewrite enabled, .htaccess permissions.

    Don't know about vars.php - I'll look into that next, but not much hope there now. And I'm also using CentOS.

    So if you figure it out - please post here so I can know too.

    Thanks.

  3. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Which permalink structure were you trying. Some don't work on less than Apache 2.0.

  4. Chris_K
    Member
    Posted 6 years ago #

    MyklK - last CentOS server I built had mod_rewrite on by default (which is good!) but AllowOverrides wasn't enabled in apache.conf for my site.

    Have you checked to make sure it's on for yours?

  5. MyklK
    Member
    Posted 6 years ago #

    No - I did not check AllowOverrides in apache.conf. I'll report back what I find. Thank you so much for helping out!

    Ok - showing my stupidity. When I go into my Apache interface (Webmin) I can look at what it calls the config file - which is actually httpd.conf. Is this the same thing? Because it says "AllowOverrides None" in there :(

    I'm assuming I don't want to change that to "All" so I'll have to figure out what lies somewhere in between. But it looks like I'm sniffing down the right road... very exciting.

    I'm not a Linux Admin - but I play one on the Internet ... My hosting services has great tech support too if I need it (I don't know if advertising in here is appropriate so I won't mention them.)

  6. MarkRH
    Member
    Posted 6 years ago #

    I was just browsing around and saw this. If your server is like mine, the $_SERVER['SERVER_SOFTWARE'] variable comes back as "WebServerX" and not "Apache".. thus it thinks it can't write to the .htaccess file to create the mod_rewrite rules for the permalink structures. So, I had to edit the vars.php file and force $is_apache to be true:

    // Server detection
    //$is_apache = ((strpos($_SERVER['SERVER_SOFTWARE'], 'Apache') !== false) || (strpos($_SERVER['SERVER_SOFTWARE'], 'LiteSpeed') !== false)) ? true : false;
    $is_apache = true;

Topic Closed

This topic has been closed to new replies.

About this Topic