WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pretty Permalink Issues (.htaccess) (10 posts)

  1. Techfreep
    Member
    Posted 8 years ago #

    Hi there, everyone. I spent the better part of today looking around google for help with activating permalinks. I've looked up and down, on forums and sites and everything, and now, five hours later, I'm still getting a 500 error when I try to activate any structure besides the default ?p=1 and whatnot.

    My .htaccess file generates in my host's root folder automatically when I delete it, but my wordpress files aren't in the root directory. Does this have something to do with the issue?

    Here's what my .htaccess looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Pretty standard -- but do I need to change the RewriteBase / or the /index.php, or both to point it to my wordpress files?

    Any help would be greatly appreciated guys, I'm nearing the point of no return.

  2. yosemite
    Member
    Posted 8 years ago #

    What are the 2 URI's you have in Options:General?

  3. Techfreep
    Member
    Posted 8 years ago #

    My two URI's are:

    (WordPress Address)
    http://s94320639.onlinehome.us/mz/tf/wordpress

    and

    (Blog Address)
    http://techfreep.com

  4. Chris_K
    Member
    Posted 8 years ago #

    Change blog address to http://techfreep.com/wordpress

    Then what happens?

  5. Techfreep
    Member
    Posted 8 years ago #

    Well, right now I have the domain techfreep.com pointed at s94320639.onlinehome.us/mz/tf/wordpress, so adding /wordpress would be the equivalent of s94320639.onlinehome.us/mz/tf/wordpress/wordpress.

  6. moshu
    Member
    Posted 8 years ago #

    WP usually hates any "pointed domain" solutions... and a lot things don't work properly with such setup.

  7. Techfreep
    Member
    Posted 8 years ago #

    That said, I did try changing it to techfreep.com/wordpress and I'm getting the same error 500...

    I get this error not only when I click on the link heads, but for all pages other than the index.

  8. Techfreep
    Member
    Posted 8 years ago #

    This sounds like it might be on target, moshu. I'll give it a shot!

  9. Techfreep
    Member
    Posted 8 years ago #

    I've officially shuffled the nameservers so there's no more "pointing" involved. I'll report back when the changes have taken place. Thanks in the mean time, guys!

  10. Techfreep
    Member
    Posted 8 years ago #

    Thanks so much moshu -- changed the DNS and everything's fine now. Thanks for the pointer!

Topic Closed

This topic has been closed to new replies.

About this Topic