WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pretty Links works but 403 on new pages (5 posts)

  1. jettrush
    Member
    Posted 4 years ago #

    I implemented Pretty Links on my blog and it worked great for the pages that already existed. This is the structure: "example.com/about/"

    But now, when I add new pages, I am only able to access them via the "almost pretty" structure: "example.com/index.php/team/"

    Going directly to "example.com/team/" produces a 403 Forbidden message. Any thoughts?

  2. alism
    Member
    Posted 4 years ago #

    Does it still happen if you disable all your plugins?

  3. jettrush
    Member
    Posted 4 years ago #

    I disabled the only active plugin, Disable Canonical URL Redirection and it does not seem to make a difference.

    From Dashboard > Permalinks, my custom structure is /%category%/%postname%/. But WordPress is telling me that my .htaccess is not writable. It is set to 766, but I had to paste in the rewrite code manually.

    When I go to look at my pages from Dashboard > Pages, I see that my permalinks for each of my pages are structured like this: /index.php/services/ instead of the expected structure. The only part of the slug that I can edit is services.

    And still, the issue persists: some pages resolve at the custom structure while others 403 Forbidden. Comments appreciated.

  4. jettrush
    Member
    Posted 4 years ago #

    Update

    It seems that none of the settings that I have discussed thus far are causing this issue. I am now able to add pages and land on them at the expected, "pretty" URL structure.

    The two pages that were not working are still resolving as "403 Forbidden". If I delete them and recreate with the same name, there is no change. But if I rename them, I am able to resolve at the new expected, "pretty", URL structure.

    I am new to databases. Does this indicate corrupted entries that I need to erase in order to create pages with those desired slugs again?

  5. jettrush
    Member
    Posted 4 years ago #

    Solution Found. This turned out to be something unforgivably simple!

    If you are experiencing an issue where some of your WordPress pages are "403 Forbidden" check your site. If you already have files or folders in the same directory as your WordPress install by the same name as the page you are trying to see, you might be a redneck.

    No but seriously, WordPress is not able to resolve at a page located at example.com/team/ if you have a "team" directory there already!

    Delete or rename the file or folder and you should be ready to go.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.