WordPress.org

Ready to get started?Download WordPress

Forums

Press This 404 issue (12 posts)

  1. kreansocerplayer
    Member
    Posted 6 years ago #

    I'm having trouble getting "Press This" working on the new WordPress 2.6. I get a 404 error every time. I'm thinking this is a relative path issue, but I could be wrong. Every time I click my created "Press This" bookmark, it gives me the 404 message for whatever site I'm trying to blog about. If I go to a Fox News article and click it, I get a 404 message FROM Fox News.

    I really want to get this feature working! Gah... this is frustrating

  2. noname1
    Member
    Posted 6 years ago #

    there is a thread about this yesterday. search?

  3. kreansocerplayer
    Member
    Posted 6 years ago #

    I attempted a search ("404 press this"), and I didn't find anything. Would you be so kind as to supply the link? I appreciate the help.

  4. kreansocerplayer
    Member
    Posted 6 years ago #

    Anyone?

  5. kreansocerplayer
    Member
    Posted 5 years ago #

    Please, can't somebody help address this issue?

    Perhaps if I add more details...

    When I try to use "Press This!" when at the page http://www.sample.com/articleIWantToBlog, I'm redirected to http://www.sample.com/articleIWantToBlog/MYWORDPRESSSITE/wp-admin/press-this.php etc.

    It's a problem with relative/full path directors. I just need to figure out why the booklet tries to access the press-this.php file at the site I'm visiting.

    Please help!

  6. qvprof
    Member
    Posted 5 years ago #

    Try this.

    It has to do with the URI Encoding getting mixed up with the mod_rewrite...

    the part where it says u='+e(l.href)+' change it to u='+e(l.href.replace(/\//g,'\\/'))+'

    so my 'Press This' code would be
    javascript:var d=document,w=window,e=w.getSelection,k=d.getSelection,x=d.selection,s=(e?e():(k)?k():(x?x.createRange().text:0)),f='http://wealthhack.com/wp-admin/press-this.php',l=d.location,e=encodeURIComponent,g=f+'?u='+e(l.href.replace(/\//g,'\\/'))+'&t='+e(d.title)+'&s='+e(s)+'&v=2';function a(){if(!w.open(g,'t','toolbar=0,resizable=0,scrollbars=1,status=1,width=720,height=570')){l.href=g;}}a();void(0);

    For my blog WealthHack.com your blog wil have your domain in the Press This link.

  7. freelance08
    Member
    Posted 5 years ago #

    I don't know about anyone else, but qvprof's solution worked for me. Thanks qvprof!

  8. The Lucky Ladybug
    Member
    Posted 5 years ago #

    *Thank You* qvprof! That little snippet made it work :) The "page not found" has been driving me nuts. This will work, but it still doesn't pick up the page url. I'm still going to checkout the QuickPost plugin.

    Thanks again for sharing a workable solution!!

  9. talkingdigital
    Member
    Posted 5 years ago #

    Ya. This looks promising. So, is someone going to create a patch of some sort for this problem? I have no idea where to go to fix the code mentioned above.

    If you could point me in the right direction, that would be cool.

    Thanks in advance.

  10. aaronrogers
    Member
    Posted 5 years ago #

    This worked perfectly for me. Thanks for your help.

  11. talkingdigital
    Member
    Posted 5 years ago #

    Is this in the press-this.php? I don't see this code anywhere in that file. Where do I go to change this? Thanks again.

  12. missadventures
    Member
    Posted 5 years ago #

    I've been trying to fix this bug for a while. Qvprof's fix worked for me. The key is also to make sure that the script has your domain name after the "f=". Previously, it just had the wp-admin bit, which was trying to call up the admin page from the site I was wanting to blog about. Thanks for helping, qvprof!

Topic Closed

This topic has been closed to new replies.

About this Topic