WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Presentation - Theme Error: array_keys() (5 posts)

  1. fusionjedi
    Member
    Posted 6 years ago #

    Just installed a new copy of WordPress 2.3.3 onto server and everything seems fine except on the "Presentation > Themes" page I have this error:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /www/hostsnake.com/f/u/s/fusionjedi/htdocs/wp-includes/theme.php on line 298

    I wouldn't mind this error except for the fact that it won't display the current theme or let me change to new themes.

    If someone is willing to help me I'd be willing to give them access to the admin to login and see the error.

    Please help if you have any ideas on how to fix this.

    Website is: heatherstasson.com
    Host is: hostsnake.com
    PHP version is: 5.1.6
    MySQL version is: 5.0.x
    Apache version is: 2

  2. fusionjedi
    Member
    Posted 6 years ago #

    deleted all files and database, uploaded fresh copy. Everything works. This is however the 3rd fresh copy. I have no idea why it didn't work the previous 2 times.

    But all is well.

  3. timt
    Member
    Posted 6 years ago #

    Deleted all files? Does that mean I will lose the last three days and nights of working on this blog?
    What could have caused this? I can't find much info on it, heck I can't even find my other post where I posted the error. I did back up my ambient glo files occasionally, but did most of the changes today. ;-(

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /nfsn/content/gazetotheright/public/wordpress/wp-includes/theme.php on line 298

  4. timt
    Member
    Posted 6 years ago #

    Ok, now it's changed to this when attempting to access from the web:

    Warning: require() [function.require]: Unable to access /nfsn/content/gazetotheright/public/wordpress/wp-includes/compat.php in /nfsn/content/gazetotheright/public/wordpress/wp-settings.php on line 117

    Warning: require(/nfsn/content/gazetotheright/public/wordpress/wp-includes/compat.php) [function.require]: failed to open stream: Permission denied in /nfsn/content/gazetotheright/public/wordpress/wp-settings.php on line 117

    Fatal error: require() [function.require]: Failed opening required '/nfsn/content/gazetotheright/public/wordpress/wp-includes/compat.php' (include_path='.:/nfsn/apps/php5/lib/php/:/nfsn/apps/php/lib/php/') in /nfsn/content/gazetotheright/public/wordpress/wp-settings.php on line 117

  5. xianlongz
    Member
    Posted 5 years ago #

    I faced this problem twice. The first time i deleted it and restart everything, and i did from scratch. But do not worry. the second time i manage to solve the problem. If you go to your FTP application. You will realise you cannot access to wp-content because the permission is set to 000. So you have to go to your website control panel.

    Change the permission to 755. Now check your website whether it is working.
    You will see that it is using the default template

    now change to your desire theme, and activate all the plugins again and your site should be fine.

Topic Closed

This topic has been closed to new replies.

About this Topic