WordPress.org

Ready to get started?Download WordPress

Forums

Mantra
[resolved] Presentation Page Slider stuck on Loading (19 posts)

  1. jessicaframedup
    Member
    Posted 1 year ago #

    I installed Mantra and on the Presentation page the slider is stuck with loading with a spinning circle that never stops. I deleted the theme and reinstalled it and it is still stuck loading. Please help! I would really like to use this them but I can't if my home page doesn't work right.

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Try disabling plugins to find whether any are responsible.

  3. jessicaframedup
    Member
    Posted 1 year ago #

    I have all plugins disabled and it still doesn't work. Any other suggestions?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Link the problematic webpage for us to diagnose.

  5. jessicaframedup
    Member
    Posted 1 year ago #

  6. rosper
    Member
    Posted 1 year ago #

    You have a jQuery conflict on the slider.

    Error: TypeError: jQuery(...).nivoSlider is not a function
    Source file: http://jessicaframedup.com/lampstandpc/
    Line: 184

    Find where you called the nivoSlider function and replace jQuery with $ sign.

    Good luck

  7. jessicaframedup
    Member
    Posted 1 year ago #

    rosper,
    I don't really know how to change what you listed. All I did was install the Mantra theme and change the presentation page to enable. And it doesn't work. So, I don't know how to fix what you mentioned above. Any more help you can give?
    If this isn't an easy fix I think I may give up on mantra...

  8. rosper
    Member
    Posted 1 year ago #

    Hi jessica,

    I looked deep at your theme.You need to acces your ftp and in your Mantra theme you have a file named header.php,open it in a editor and change:

    <script type="text/javascript">
    
    	// Flash animation for columns
    
        jQuery(window).load(function() {
    	// Slider creation
            <strong>jQuery</strong>('#slider').nivoSlider({
    
    			effect: 'random',
           		animSpeed: 750,
    						pauseTime: 5000
    						});
    
        jQuery('#front-columns > div img').hover( function() {
    	      jQuery(this)
    			 .stop()
                 .animate({opacity: 0.5}, 100)
                 .fadeOut(100)
    			 .fadeIn(100)
                 .animate({opacity: 1}, 100) ;
    	}, function() {jQuery(this).stop();} )
    
    		});
    	</script>

    what is in bold with $ sign,save it and try if is working.

    Good luck.

  9. rosper
    Member
    Posted 1 year ago #

    Change the word jQuery from jQuery('#slider').niviSlider() with $ sign

  10. jessicaframedup
    Member
    Posted 1 year ago #

    rosper,
    thank you for the help and suggestions but I opened the header.php file for mantra and see nothing like what you have above. It doesn't even look like the slider or jQuery or script type or anything like what you mentioned above is even in this file. So I have no idea what to change, add or alter... I'm thinking this may be beyond my expertise. And I'm concerned that even if I do get the right file changed correctly that if there is an update it will alter it and then won't work again. Any other thoughts?

  11. rosper
    Member
    Posted 1 year ago #

    Jessica,

    If is not in header.php search in index.php or in footer.php, this change will not broke the theme if you make an update.
    if you don't find the code you need someone with experience to find this JavaScript conflict.

    Thanks,
    and good luck

  12. jessicaframedup
    Member
    Posted 1 year ago #

    Well, I opened both the index.php and the footer.php and there was nothing in either one that would help. But I saw something in the index.php that reminded me about making sure that the Settings under reading were set right. I thought that it needed to be set to my home page as a static page but I reread it again and finally understood that it does not want it set as a static page but as the latest posts. It took reading a few times to really understand but I finally got it! ;-)
    "If you have this enabled but don't see a Presentation page then go to Settings » Reading and make sure you have selected Front Page Displays as Your Latest Posts." I was confused because I could see the presentation page just fine, it was the slider that wasn't working.
    Once I made this simple change the slider worked perfectly. :-)
    Thank you so much for your help because it helped me finally figure out what the simple fix was! I really appreciate it! And hopefully this will help others that run into the same problem.

    ------- To fix the Slider that is stuck as loading... go to Settings » Reading and make sure you have selected Front Page Displays as Your Latest Posts

  13. rmarks-CA
    Member
    Posted 1 year ago #

    Jessica,
    I had the same problem with my Mantra...I'm new to WordPress, but have quite a bit of web building experience with Adobe GoLive (no help there though).
    The Slider issue was driving me nuts. I checked folder paths, folder names, image size, file size, then I checked the "Source Code"....I could see the problem...the 'href' next the the source reference 'src' for the Sliders was MISSING for all of my Slider images. I knew What the problem was, but couldn't get the problem solved.
    I accidentally came across your question about the slider problem, and was delighted that you had the amazing insight to solve the problem. Simply and Easily. Wow.
    I too thought that if I wanted the Home/Presentation Page "Static"...I must set the "Setting/Home Page" to static....Silly me.

    Bless you and the ground that you walk on for solving this problem.

    I can't tell you how grateful I am to you Jessica....your solution worked GREAT.
    Thank you from the bottom of my heart....rmarks-CA

  14. lushb0x
    Member
    Posted 1 year ago #

    For those who are still having problems(I was, I am using a hybrid wordpress install) you will find the described text in "wp-content/themes/mantra/includes/theme-frontpage.php

  15. annaco
    Member
    Posted 1 year ago #

    I have just downloaded and installed theme Mantra. I have the same issue. What I did:
    1. Settings » Reading selected Front Page Displays as Your Latest Posts.
    2. Disabled ALL plugins
    3. in wp-content/themes/mantra/includes/theme-frontpage.php changed jQuery to $
    Still the problem persists. If I do not have the presentation page "enabled, i wll see all posts that need to show on the slider. Once I select :enable, I See the slider stuck on trying to download.
    Any other suggestions? I do have the latest version of wordpress and mantra. Or do you have a suggestion for a similar theme that works? TNX
    annacorealestate.com

  16. ronis99
    Member
    Posted 1 year ago #

    Guys,

    I have similar problem to yours. The only thing is that I messed around with jquery but no result. I am sure is working and it shows the text of my "recent posts" but I tried everyhting for the images to showed up and I did not figure it out so far. Any advice appreciated.
    My site is easyfootball4you.com...newest wordpress and mantra theme.

  17. cherey2001
    Member
    Posted 1 year ago #

    I have the same problem with my website http://www.aa-gorilla.com. The homepage, which you can see the slideshow is not loading. I hope anyone can help me to solve the issue. Thanks in advance.

  18. cherey2001
    Member
    Posted 1 year ago #

    solved. jquery conflict. It should be disabled

  19. CryoutCreations
    Member
    Theme Author

    Posted 1 year ago #

    WordPress recommends using jQuery instead of $ to avoid compatibility with other jQuery-like javascript libraries that may be overloading the $ sign.
    So changing "jQuery()" to "$()" in Mantra will not resolve this issue.

    You need to figure out if you're using the correct WordPress/Mantra versions combination (As of version 1.8, Mantra requires at least WP 3.3).

    If this is correct, make sure the image links you set for the slider are correct (try to access them in a separate tab directly and see if they work and are publicly accessible).

    If this is not the case, a plugin may be interfering with WordPress' bundled jQuery. Try disabling all plugins and see if the issue goes away.

    If this isn't the case either (or you have no plugins), then it could be indeed an issue with the theme, and you should let us know about it :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic