WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] [closed] Premium options missing (9 posts)

  1. yuzairy
    Member
    Posted 1 year ago #

    After latest premium update, I got error when trying when trying to add new plugin through backend. Reason is that when Testimonial Widget Premium is active, it's preventing the site from communicating with WP plugins API.

    I've tried to delete the Testimonial Widget Premium and reupload a fresh copy and reactivated.

    But now it seems that the site is not recognising that I have premium version installed. The Testimonial Widget Premium options missing as if I have only the free version.

    Free version: 2.11.1
    Premium version: 1.11.0

    Also now the sidebar is not returning any testimonials (it was fine before).

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. yuzairy
    Member
    Posted 1 year ago #

    Got the testimonials to show.

    But still it doesn't detect that I have Premium installed.

  3. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    How did you determine that Testimonial Widget Premium is "preventing the site from communicating with WP plugins API"?

    I think that I'm not able to reproduce the situation on dev or live.

    Can you send me an admin login via http://aihr.us/contact-aihrus/?

  4. yuzairy
    Member
    Posted 1 year ago #

    How did you determine that Testimonial Widget Premium is "preventing the site from communicating with WP plugins API"?

    >> WP throws an unknown error while I was trying to search for plugins from repository via backend. And the only change before the error was the update for both Testimonial Widget Free & Premium. True enough, deactivating the Premium version allows the plugin search to work.

    Strangely enough, when I re-uploaded and re-activated the testimonial widget premium plugin again (redownload from my purchase history), I cannot reproduce the error.

    But another problem came up which is the install doesn't recognize I have the premium version installed.

    That's the story :)

    I've sent my login via your contact form just now.

  5. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    I've confirmed this as a bug and will need time to duplicate and resolve. Please be patient while I do so.

  6. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    I've got the plugin API issue resolved, but am still working on the settings. Also, I'm taking time to write a new suite of tests and release preparation tools to try and prevent issues like this from happening in the future.

  7. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    A bit of frustration, Premium settings are back in the Testimonials > Settings, but not in widget options upon saving. I'll need further time to debug that.

    Once all of the above issues are resolved, I'll make new Testimonials Widget and Testimonials Widget Premium releases.

  8. yuzairy
    Member
    Posted 1 year ago #

    Thanks for the update Michael.
    Looking forward for the solution.

  9. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    All fixed. Testimonials Widget 2.11.2 and Testimonials Widget Premium 1.11.1 are released. Please update to those.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic