WordPress.org

Ready to get started?Download WordPress

Forums

Precondition Failed (35 posts)

  1. richards1052
    Member
    Posted 8 years ago #

    Thanks for those directions. That helped. But I got 5,000 instances of the term 'Google' so that prob isn't going to narrow things down much. I also tried services.google.com as that's the URL for the Google Remove URL feature but that came up empty handed.

    Starting to feel like a needle in a haystack. I'll prob. give up for now & come at it once more if the problem arises again. But thanks again for sticking w. me & trying to help.

  2. kjarrett
    Member
    Posted 8 years ago #

    This is for MacManX or whomever reads it...

    We encountered this error for the first time on several blogs I run at my school. All are WP 1.52 and BB 1.2.4. As MacManX suggested, disabling BB solved the problem ... but I am confused a bit.

    1) Why did this happen now, all of a sudden? Of the blogs in question, mine (http://www.ncs-tech.org) has been running in this configuration for quite a while (months?) with no problem.

    2) MacManX's post says to "add the IPs to Bad Behavior's whitelist." Add WHAT IPs? The ones in the database error log? I need to go dig them up.

    3) How does this problem occur? In layman's terms (I'm not a coder and didn't stay at a Holiday Inn Express last night) ... I don't understand how an external thingamabob like the lack of some remote system's IP address in a whitelist file can prevent my blog from displaying when I am browsing it.

    Thanks all!

    -kj-

  3. 1. http://error.wordpress.com/2005/09/30/what-to-do-when-bad-behavior-blocks-you-or-your-friends/

    2. Yes, you will need to recover the friendly IPs listed in the database and whitelist them, or read the reason for Bad Behavior interception and correct the problem.

    3. Please refer to the answer for #1.

  4. kjarrett
    Member
    Posted 8 years ago #

    It's baaaaaaaaaaaaack.

    How do I whitelist my IP?

    -kj-

  5. jvyduna
    Member
    Posted 7 years ago #

    Since this is the preeminent post on WordPress Precondition Failed, I thought I would add this hint.

    I was receiving Precondition Failed when trying to view WordPress blogs NOT using the Bad Behavior plugin.

    If you use the iOpus iMacros browser plugin, it will add the user agent string (browser identification) "iOpus-I-M;" One place you can view what user agent information your browser is giving sites is at Anonymouse, click the "Calling Card Without Anonymouse" link.

    The XP/IE6 registy location to check for and remove offending strings is:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform]

    After removing the iOpus-I-M DWORD key, I was able to view these WordPress sites again.

Topic Closed

This topic has been closed to new replies.

About this Topic