WordPress.org

Ready to get started?Download WordPress

Forums

[closed] "Precondition Failed" Problem. Need help please. (14 posts)

  1. Kitana Khan
    Member
    Posted 2 years ago #

    Precondition Failed

    The precondition on the request for the URL /prototype/wp-admin/media-upload.php evaluated to false.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I get the above error message whenever I try to insert an image into my page/post. Everything worked fine for months since until about 3 weeks ago. I've tried everything I could think of to no avail.

    I have other sites running on 3.2.1 with no image upload/insertion issues.

    Please help.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. Kitana Khan
    Member
    Posted 2 years ago #

    esmi,

    thanks for the response. I'll try your suggestions and update this post.

    Thanks!

  4. Kitana Khan
    Member
    Posted 2 years ago #

    Update:
    * I've tried deactivating all plugins but the problem's still there - images upload/crunch fully until I click "insert into post". :(

    Going to try switching to the twenty eleven theme now.

  5. Kitana Khan
    Member
    Posted 2 years ago #

    Update:
    * I've tried switching to the twenty eleven theme but no luck.

    Going to try resetting the plugins folder now. :(

  6. Kitana Khan
    Member
    Posted 2 years ago #

    Update:
    * Still no luck after resettig the plugins folder.

    Need help please.

  7. Kitana Khan
    Member
    Posted 2 years ago #

    will upgrading WP help?

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Highly unlikely. This is specific to your site. Have to asked your hosts about this? It could be server config issue.

  9. Kitana Khan
    Member
    Posted 2 years ago #

    server configuration? but it used to work just fine!

    anyways, are there any specific server configurations from the host that could affect WP in this way? I mean, if there's anything specific I should ask about?

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    are there any specific server configurations from the host that could affect WP in this way

    Sorry but that's like asking how long is a piece of string. There are as many server configurations as there are servers. And it is not uncommon to find different config with the same host. The error message is server-related. It's not coming from WordPress.

  11. Pepperfly
    Member
    Posted 2 years ago #

    I'm currently experiencing the same problem with my hosting service. I am pretty certain that it's a mod_security issue. I've vainly tried everything under the Sun to filter the file that exploits the precondition via my .htaccess file. But I recently discovered that there's nothing I can do myself to resolve the issue. Since v2.5, Mod_security no longer allows for disabling using one's .htaccess -- the httpd.conf must be edited. You need to contact your hosting service tech support and request to have mod_security disabled (i.e., commented out and whitelisting the domain). I hope my hosting service tech support handles this soon! I'll report back here and give an update.

  12. Pepperfly
    Member
    Posted 2 years ago #

    Here's that update. My host indeed disabled mod_security. I am now able to insert images into posts without encountering the HTTP error. I am curious to hear back from @levelsevenltd as to the status of the original problem.

  13. K Rameswaran
    Member
    Posted 2 years ago #

    Hi Mr. Krisha;

    Thank you for your kind replay. this is not others topic it's my wordpress site problem. even i tried to all ideas given by the members. modification of .htaccess even though its not solved my problem. finally i went to my database and deleted the few entries and again deactivate all the plugins and activate now the problem is solved.

    apart from my hosting server also blocked my system IP address now i am working on it.

    Thank you for your kind help. i need your ideas and support for developing my site in more useful way.

  14. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    You seem to misunderstand. Instead of posting your questions on other pages like this, open your own topic so that you will get better attention.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.