WordPress.org

Ready to get started?Download WordPress

Forums

Precondition Failed error (8 posts)

  1. onegear
    Member
    Posted 7 years ago #

    i've been having problems making changes to the sidebar of the WordPress Default theme. when i make a change and try to save it, i receive the following error:

    Precondition Failed

    The precondition on the request for the URL /blog/wp-admin/theme-editor.php evaluated to false.

    this has happened on other themes, as well. i'm running the latest release of wordpress, if that information is needed.

    thanks for your help.

  2. onegear
    Member
    Posted 7 years ago #

    does WP ship with some sort of spam control? i'm reading online that this may be causing the problem.

    thanks

  3. onegear
    Member
    Posted 7 years ago #

    where would i "shutoff" the spam control that could possibly be causing this issue? i've searched for this but can't figure it out.

    thanks.

  4. onegear
    Member
    Posted 7 years ago #

    is there a way to shutoff spam control in wordpress? each time i attempt to edit anything other than the stylesheet, i receive the above error. it's become very frustrating because i'm unable to make any changes to my blog's appearance.

  5. whooami
    Member
    Posted 7 years ago #

    thats not wordpress.

    thats mod_security.

    add

    SecFilterEngine Off

    to your .htaccess and see if it goes away.

    that will disable it for your entire domain, so if you would rather just disable it for stuff you do in the admin area, create an .htaccess (use notepad), put that code above in it .. and upload it to wp-admin/

    Or ..

    if you just want to have certain files do this:

    SecFilterEngine On
    SecFilterSelective "REQUEST_URI" "/wp-admin/edit.php" "allow,nolog"

    the above would go in the root .htaccess NOT in a /wp-admin one.

    Or, lets say you want to post a word that might be typically blocked, like 'curl':

    SecFilterEngine On
    SecFilterSelective "POST_PAYLOAD" "curl" "allow,nolog"

    Like before, that example would go in your main .htaccess

    You can see the choices are many.

    http://httpd.apache.org/docs/2.0/howto/htaccess.html
    http://www.modsecurity.org/documentation/modsecurity-apache/1.9.3/html-multipage/

  6. onegear
    Member
    Posted 7 years ago #

    thanks for your help. that resolved the issue! i tried googling it prior to submitting this request for help but wasn't really sure what to look for.

    i don't run windows so i had to use my editor of choice, vi, on my linux box. :-)

    thanks, again, for your help! that was very easy to fix.

  7. whooami
    Member
    Posted 7 years ago #

    bleh vi, pico.

    youre welcome :)

  8. onegear
    Member
    Posted 7 years ago #

    haha!! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic