WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pre-DNS move: Getting 404 error when logging into admin page (5 posts)

  1. sgruenwedel
    Member
    Posted 8 years ago #

    I have a non-WP site at Host A. I just installed WP at Host B and want to get the new site all set up before I redirect the DNS servers to the new IP address and cancel the Host A account running the old site.

    But when I try to log in to my WP admin page using the IP address, for example:
    http://123.456.76.90/wp/wp-admin/

    It redirects to this URL:
    http://www.mydomain.com/wp/wp-admin/

    Because that non-WP site has no such directory structure, I get the 404 error.

    How do I log in to my new site using the IP address that Host B provided me, without being redirected to the old site at Host A?

    Note that this URL works fine:
    http://123.456.76.90/wp/

    When I go there, I see the plain-vanilla default home page that the installer initially creates. So I can go to 123.456.76.90/wp/ but not to 123.456.76.90/wp/wp-admin/.

    (By the way, I installed using Fantastico. My Host B is Site5.)

    Am I doing something wrong?

    Thanks!

    Stefan

  2. If you want to work with WP before the DNS changes, you will have to set the "site url" and "home" values in the database to the IP address with the /wp/ directory. See: http://www.tamba2.org.uk/wordpress/site-url/

    Once your domain becomes function, you can easily change these two options back to the domain in Options/General.

  3. sgruenwedel
    Member
    Posted 8 years ago #

    Thanks for the info. I logged in to my phpMyAdmin page (it's version 2.6.4-pl2) and tried to make the first edit to siteurl as you describe. However after I click Go, the screen says "No change" and indeed the change has not been made.

    Is this an issue with permissions or something? How would I correct that? I am the sole owner of the account and indeed created this in the first place. I'm concerned that on the home page of the admin screen, under the "Create new database" link, it says "No privileges." Is that a clue that I don't have permission to edit the database tables?

    Stefan

  4. I recommend that you contact your hosting provider.

  5. sgruenwedel
    Member
    Posted 8 years ago #

    Yipee, I fixed the problem! ;-)

    Well, I had help. I found out from my web host's customer support how to log in to phpMyAdmin so I could make the changes that your very clear, very understandable tutorial explains.

    After I set my IP address as my site URL, I had no problem logging in to the WP admin page at:
    http://123.456.76.90/wp/wp-admin/

    Thanks for your help!

    Stefan

Topic Closed

This topic has been closed to new replies.

About this Topic