WordPress.org

Ready to get started?Download WordPress

Forums

Posts, when clicked on, lead to 404 error (16 posts)

  1. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    I created a post. When I click on the title of the post, that is a hyperlink, I get a 404 error or "the page cannot be found."

    Please advise. Thank you.

  2. whooami
    Member
    Posted 7 years ago #

    how bout a link to a blog?

  3. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    Whooami, thank you.

    When I create a post within my blog, this works fine. Post appears on Front Page and title of the post is a hyperlink. When I click on the title, I get a 404 error.

    Maybe I need to make the title NOT be a hyperlink. That makes sense.

    How do I do this?

  4. moshu
    Member
    Posted 7 years ago #

    You post too much and don't read.
    She was asking you for a link to the blog so we can see it!
    (what you said about making the title NOT a hyperlink - doesn't make sense, btw)

  5. IcelandDream
    Member
    Posted 7 years ago #

    You want it to be a hyperlink unless you want the posts to be 404 forever when it is not on the front page. How about link and we'll see the reason. Likely a permalink config problem.

  6. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    Okay... Happy to oblige. Here's the blog I'm working on:
    http://www.unitedwaytwincities.com/wordpress/

    Note when you click on the title of the post that reads "Northwest Airlines and United Pillsbury Communities" it links to a 404 page.

  7. IcelandDream
    Member
    Posted 7 years ago #

    permalink.
    If you change it back to the default "ugly" permalink it should work. If it does than you have to find out if your .htaccess file is correct or being ignored.

  8. moshu
    Member
    Posted 7 years ago #

    1. Delete that huge picture...
    2. Reset your permalinks to the default setting.
    3. Read: Using_Permalinks

  9. moshu
    Member
    Posted 7 years ago #

    ID is faster by 10 seconds :)

  10. IcelandDream
    Member
    Posted 7 years ago #

    :)

  11. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    I changed the permalinks to add navigation links to the header. I hope by changing back to default the navigation links still work.

    And thanks for the suggestion to delete the mammoth photo. Blog hasn't been promoted, so you are the first to see it and photo was uploaded as a test.

    By the way, you are all fast!

    Thanks much!

  12. moshu
    Member
    Posted 7 years ago #

    I changed the permalinks to add navigation links to the header.

    That has nothing to do with the permalinks!

  13. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    I changed permalinks to default setting. Now the navigation links above the header image do not work.

    Ideas? http://www.unitedwaytwincities.com/wordpress/

  14. moshu
    Member
    Posted 7 years ago #

    This one will never work:
    wordpress/For the Media/">
    NO SPACES! I guess this one has been edited by you!

    As for the others... it is a bad practice from the theme designer to hardcode those links. I know he is a famous designer but that is still a crappy practice.

    And for you now it is the time to go and read the instructions about the permalinks. I gave you a link to it above.

  15. UnitedWayTwinCities
    Member
    Posted 7 years ago #

    I did follow the theme designer's directions on adding navigation links to the image header.

    I am not a web designer. (I know you're surprised.) I don't know CSS. However, I could follow Cutline designer's instructions. Reading the page on using permalinks is not helpful. It's not step-by-step enough.

    Do I have other options to make the navigation links work?

  16. moshu
    Member
    Posted 7 years ago #

    No, you don't.

    There is nothing about designing.
    It is a two (or 3?) steps process.
    Make your .htaccess file writable = chmod 666.
    Set your permalink to the desired structure (and let WP write to the .htaccess file)
    Done.

    Your Pages are there just inaccessible because of hoe you coded the navigation:
    e.g. http://www.unitedwaytwincities.com/wordpress/?page_id=2

    However, if you make a Page titled "For the Media" - the link (the slug) to it should be example.com/for-the-media - no matter what you read in any instructions.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags