WordPress.org

Ready to get started?Download WordPress

Forums

Shortcodes Ultimate
posts tax_term category number (16 posts)

  1. 3-4-SAD
    Member
    Posted 7 months ago #

    Hello,

    Posts shortcode shows category ID numbers instead of category names.
    I get an error message "Posts not found"

    Original shortcode was:
    [su_posts template="templates/teaser-loop.php" posts_per_page="6" tax_term="2"]

    And when I change the category ID number it to category-name (slug) then it works:
    [su_posts template="templates/teaser-loop.php" posts_per_page="6" tax_term="blog"]

    Is it just me or someone else has the same problem?

    http://wordpress.org/plugins/shortcodes-ultimate/

  2. Narthur
    Member
    Posted 7 months ago #

    Yes, I had the same problem, and your solution fixed it! Thanks for sharing.

  3. afjsystem
    Member
    Posted 7 months ago #

    hi sad.. which version do you use ?

    is it work for default-loop template too ?

  4. 3-4-SAD
    Member
    Posted 7 months ago #

    Hello,
    I have WP 3.8 and Shortcodes ultimate Version 4.5.3

    I have the same issue on several other sites.

  5. Narthur
    Member
    Posted 7 months ago #

    WP 3.8 with Shortcodes Ultimate v4.5.3 here, too.

  6. techretaries
    Member
    Posted 7 months ago #

    I have the same issue.

  7. 3-4-SAD
    Member
    Posted 6 months ago #

    I guess it has to be only me and a few other people since nobody else is complaining about the post shortcode. Can somebody confirm that this is working? Please, try to insert post shortcode into page or post and see if it displays correctly.

  8. webdotcom
    Member
    Posted 6 months ago #

    Same here. Posts shortcode not working, no matter what I tried so far.

    Latest WP and Plugin

  9. 3-4-SAD
    Member
    Posted 6 months ago #

    Hello Vladimir.
    Would You please be so kind and take a look at this problem.

  10. 3-4-SAD
    Member
    Posted 6 months ago #

    Hello Vladimir.
    Would You please be so kind and take a look at this problem.

  11. Vladimir Anokhin
    Member
    Plugin Author

    Posted 6 months ago #

    Hello all,

    I'll add this issue to my to-do list.

  12. webdotcom
    Member
    Posted 6 months ago #

    Vladimir,

    Any idea on a timeframe? Or maybe a suggestion for a manual fix until then? Regardless, Thank you for the great work you've done with the plugin... it's an awesome plugin!

  13. Marc MTL
    Member
    Posted 5 months ago #

    having the same problem here..
    works with the slug but not with the category id.
    Any news/help?
    Thanks

  14. jkl006
    Member
    Posted 5 months ago #

    The manual workaround works fine for me, but does anyone have insight about categories or terms with multiple words?

  15. Vladimir Anokhin
    Member
    Plugin Author

    Posted 5 months ago #

    Fixed version is available on GitHub and will be available at wp.org in next few days.

    Now you can use category slugs or Ids.

    v4.6.0

  16. 3-4-SAD
    Member
    Posted 5 months ago #

    I confirm that now it works.
    Good job Vladimir and thanks for this awesome plugin.

Reply

You must log in to post.

About this Plugin

About this Topic