WordPress.org

Ready to get started?Download WordPress

Forums

posts problems (13 posts)

  1. lalucia
    Member
    Posted 2 years ago #

    Hi

    I have been trying to make a site structure for my site so I have a static home page and am trying to build the horizontal menu by categories and sub categories and some pages.

    I have tried to make a post that is found via the category on the menu and that is an excerpt sticky on the from page. I have a few problems....

    Although I ticked the box that says make this post a sticky on front page..... Nothing hapened Front/home page is blank.

    I uploaded an image and aligned it at Centre but it will only show as aligned to the left.

    I have tried deleting post and starting again - same thing happens.
    I have tried to ensure the cursor is centred before I upload ... still aligned left.
    I am not a coder but when I look at the code is says aligncentre so what is happening?

    I tried the same on a page and everything was fine - image centred and so on......

    Please does anyone know what could be the problem with the sticky and the image?

    Thanks L

  2. aphill70
    Member
    Posted 2 years ago #

    The reason your sticky post is not visible on the front page is because you have a static front page. you would need to put some sort of custom code in the page.php or front-page.php in order to get a post sticky to a static front page.

    You could just hard code the text into whatever page you are using as your homepage...

    about the image you are probably missing the css for centered images.

    http://codex.wordpress.org/Styling_Images_in_Posts_and_Pages

    the default css styles are found at the above link if you just add it to the bottom of your style.css that should solve the problem with the image centering unless there is some other problem...

  3. lalucia
    Member
    Posted 2 years ago #

    Thanks for that - I wish WP mentioned the static page bit for the stickies!! Never mind I can make them with a four column shortcode in my theme and put them there manually.

    Now to reveal that I am a muppet.....

    When you say style sheet do you mean in the HTML bit of the post or somewhere more (to me) deadly and dangerous. If the latter, please could someone tell me exactly how to get there please?

    Why is the image align code missing? Is it a bug from my theme or the upgrade I wonder?

    Thanks v much

  4. aphill70
    Member
    Posted 2 years ago #

    the align code is part of the theme and some themes don't implement them right... if it was working then maybe they added some new css that overrode it.

    if you just go to your appearance->editor you should see your stylesheet style.css

    just add the following to the bottom of that file and click update.

    img.alignright {float:right; margin:0 0 1em 1em}
    img.alignleft {float:left; margin:0 1em 1em 0}
    img.aligncenter {display: block; margin-left: auto; margin-right: auto}
    a img.alignright {float:right; margin:0 0 1em 1em}
    a img.alignleft {float:left; margin:0 1em 1em 0}
    a img.aligncenter {display: block; margin-left: auto; margin-right: auto}
  5. lalucia
    Member
    Posted 2 years ago #

    Hi thank you for your help....

    This is what the style sheet says (section 17 basic WP blog styles )

    /* Images */
    .entry-content img {
    margin:0 0 1.5em 0;
    }

    .alignleft,
    img.alignleft {
    display:inline;
    float:left;
    margin-right:1.5em;
    }

    .alignright,
    img.alignright {
    display:inline;
    float:right;
    margin-left:1.5em;
    }

    .aligncenter,
    img.aligncenter {
    clear:both;
    display:block;
    margin-left:auto;
    margin-right:auto;
    }

    There is one other section beneath that for special fonts. Do I paste the code you gave me at the bottom of the lot or at the bottom of the image section? Do I leave the original code there?

    I'm scared of messing up the theme.... sorry to impose...

    Thanks

  6. aphill70
    Member
    Posted 2 years ago #

    no worries adding these styles at the very bottom of the file will ensure that if something is overriding them they will be fine you could even just replace those lines with the ones i gave you.

    if you want to give me your url i could double check what the exact problem but i am pretty sure that the problem is probably a bad line of code in the aligncenter code.

    so i would guess that if you add it the very bottom of the file it will fix this problem is something else breaks you can just remove and keep troubleshooting... with no permanent harm done

  7. lalucia
    Member
    Posted 2 years ago #

    Thank you so much

    this is my URL http://digitaldjeli.com/

    The post is under the SAsia tab and then more at the end of the excerpt......

    It works fine when I originally put the article in a page but then I realised that I would end up with too many pages so decided to start again via posts.... I am just trying to get the structure sorted so I can then build my menus and things. All I did was upgrade WP and it all went pear shaped and I had to re-install the theme.

    Thanks

    L

  8. aphill70
    Member
    Posted 2 years ago #

    Ok actually it looks like if you add some space between your text and the image within the visual editor i bet that will fix it.

    what is happening is WordPress' autop filter is adding the p tags and your img is getting wrapped with your first paragraph. and that is breaking the centering rules...

  9. lalucia
    Member
    Posted 2 years ago #

    Thanks for having a look....

    I tried what you suggested and put more space and while the text is now in the right place the image is still on the left even though it is set to be centred. I tried re-uploading it too.

    For a test, I tried making another page (on menu as blah blah) because this wasn't problem when I had made a page previously. Hmm now the page is doing the same thing. The image is aligned on the left.

    All I have done is made some pages (which were fine) and then deleted them. Now I have this image problem. I don't know - maybe I should reinstall everything again................ Re-install the theme maybe.

    I'll try comparing the code in my CSS with another one similar and meanwhile if anyone has any ideas that would be fab. I saw that there was another thread on the same problem about 7 pages back but it never was resolved.

    Thank you
    L

  10. aphill70
    Member
    Posted 2 years ago #

    On line 618 of your style.css you are floating the img left

    that is causing the problem because a floated element and be dynamically positioned with margin auto.

    so you could add a float: none to the aligncenter call and that would fix it or remove the offending line...

  11. lalucia
    Member
    Posted 2 years ago #

    Oh sheesh..... how do I find which are the line numbers?
    Also do I go to view page source for the dodgy page/post or do I look in editor inside WP

    DO I then put float: none before or after aligncentre?

    So Sorry to ask dumb questions. I did try googling answers before I came back here (sheepishly) - just need to find the line number really. I tried pasting into notepad but nothing indicated lines. Looked at Pastebox but you have to register and when I pasted and looked at other people's there were no line numbers...

    Step by step can anyone tell me how to find the right atyle sheet and line number please?

    Thanks......
    L

  12. aphill70
    Member
    Posted 2 years ago #

    .aligncenter,
    img.aligncenter {
    clear:both;
    display:block;
    margin-left:auto;
    margin-right:auto;
    }

    take the above line...and change it the the below...

    .aligncenter,
    img.aligncenter {
    clear:both;
    display:block;
    margin-left:auto;
    margin-right:auto;
    float:none;
    }
  13. lalucia
    Member
    Posted 2 years ago #

    aphill70 YOU ARE A KIND AND PATIENT HERO!!! THANKYOU

    It worked thank you so much - I made a new post and a new page to test it and it is fixed.

    I thought I was going to have to reinstall everything so I really appreciate your patience thank you

    Best wishes

    L

Topic Closed

This topic has been closed to new replies.

About this Topic