WordPress.org

Ready to get started?Download WordPress

Forums

JBST
[resolved] Posts page still shows widgets even though widgets are disabled (4 posts)

  1. welshdragon1987
    Member
    Posted 4 months ago #

    |Hi, I have been making bususersoxford.org (which is currently sat on an old domain at http://www.raildisruptions.co.uk), I have no widgets at all set in the theme, but the posts page still shows the Archives and Meta widgets. Are they specifically hard-coded into that page?

  2. bassjobsen
    Member
    Theme Author

    Posted 4 months ago #

    Hi,

    Thanks for posting your issue.
    Well it is some kind of hard code indeed. If you don't not define the "Page Layout" it is "right sidebar" by default. In this situation, without any widget, it will show the default sidebar.

    Please try to set the page layout to "Full width" by edit ting the page. You will find page layout in the right column, under the heading "Template options".

    Alternatively you can consider to install the Options Framework Plugin, this enables the options to the layout per page type.

    Or to set all your pages to "full width" write in your functions.php:

    function jbst_set_global_layout()
    {
    
        global $jbst_layout;
        $jbst_layout = 'full-width';
    
    }
    add_action( 'wp_head', 'jbst_set_global_layout');

    see also: https://github.com/bassjobsen/jamedo-bootstrap-start-theme/issues/104

    Note is you think there is something wrong with the default setting as described above. Please feel free to post an issue on github too: https://github.com/bassjobsen/jamedo-bootstrap-start-theme/issues/new

  3. welshdragon1987
    Member
    Posted 4 months ago #

    Thanks, Despite altering the page layout it would not remove them, I simply added a blank text post to the sidebar and it worke!

  4. bassjobsen
    Member
    Theme Author

    Posted 4 months ago #

    @welshdragon1987 nice that works.
    I got some questions / suggestion about http://www.raildisruptions.co.uk. Could you please contact me on bass@w3masters.nl, thanks.

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.