WordPress.org

Ready to get started?Download WordPress

Forums

Emerald Stretch
[resolved] Posts page not showing Blog (8 posts)

  1. stanwoodard
    Member
    Posted 10 months ago #

    Using the Emerald Stretch theme, I have the Settings>Reading Settings Front page display set to a static page called Home, and have the posts page set to a page called Blog. Upon clicking for Blog a blank page is returned. If I remove the Reading Settings for Blog, the page shows up. Can anyone help with this? Blog link is at the last one on the MENU... http://artsgeorgia.net/wp/

  2. Josiah
    Member
    Posted 10 months ago #

    Something is showing up for me. That is interesting. I had a link to here:

    http://artsgeorgia.net/wp/business/business-support-for-the-arts/

  3. stanwoodard
    Member
    Posted 10 months ago #

    Thanks for checking, Josiah
    What if you go here -- http://artsgeorgia.net/wp/blog-2/ -- do you see anything?
    This where the main blog page with multiple posts should be showing.

    What if you go here and click the blog link? http://artsgeorgia.net/wp/

  4. Josiah
    Member
    Posted 10 months ago #

    When you do a static page like that and then a blog page, sometimes there is an options in the page editor on the right side under page attributes that says template. Make sure Blog is selected there.

    I just wanted to make sure you knew that the emerald stretch theme has not been updated in 2 years, which means it may not work as well with the current wordpress setup.

  5. stanwoodard
    Member
    Posted 10 months ago #

    The Emerald Stretch theme doesn't have a native blog template but I found one that is supposedly "generic" and added it. That doesn't work either, can be seen here -- http://artsgeorgia.net/wp/posts. The complete blog.php is pasted below.

    <?php
    /*
    Template Name: Blog
    */

    // Which page of the blog are we on?
    $paged = get_query_var('paged');
    query_posts('cat=-0&paged='.$paged);

    // make posts print only the first part with a link to rest of the post.
    global $more;
    $more = 0;

    //load index to show blog
    load_template(TEMPLATEPATH . '/index.php');

    ?>

  6. stanwoodard
    Member
    Posted 10 months ago #

    Used to Display Posts Shortcode to create my Blog roll!

  7. Josiah
    Member
    Posted 10 months ago #

    So you have it working?

  8. stanwoodard
    Member
    Posted 10 months ago #

    Well, I faked a solution by creating a page called "Blog" and dropping the Display Posts Shortcode app. To make every post show up I created a category called "." and applied that to every post. Also made a Blog Page Template in order to use a custom Sidebar.

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.