WordPress.org

Ready to get started?Download WordPress

Forums

Kebo Twitter Feed
[resolved] Posts page not displaying (6 posts)

  1. LaurenWilson
    Member
    Posted 11 months ago #

    Hi Guys,

    When i began my website, despite choosing static pages, the comments section was still coming up. As I didn't want this function, i deleted the Comments.php section from my editor and solved the problem...and created a new one. I wanted to feature one posts page for jobs, however when i select it as a post page, literally nothing displays-it's just a white screen. Unless its a conflict with a plugin, then comments.php is the only thing that I could have changed to affect it.

    Does anybody have an idea of what I can do to have a blog page without adding the comments section back?

    Thanks
    Lauren

    http://wordpress.org/plugins/kebo-twitter-feed/

  2. Peter Booker
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Lauren,

    I am not quite sure how this got into my plugins support forum, but perhaps I can help anyway.

    I think the issue may be that you deleted the comments.php contents. Do you have an un-edited version of the theme files to put back, so your comments.php is back to normal? If it is one of the core themes (twentyten, twentytwelve, etc) you can get the files in the wordpress download from wordpress.org.

    If you do not want comments to be available on pages there are two things you can do:

    To Disable Comments for a Specific Page
    In the control panel go to the 'Pages' menu and when hovering over the page you want to disable comments for click 'Quick Edit'. You can now uncheck the 'Allow Comments' box.

    To Prevent new Posts/Pages from being Comment Enabled
    In the control panel go to the 'Settings' page, then 'Discussion', then uncheck the 'Allow people to post comments on new articles' box.

  3. LaurenWilson
    Member
    Posted 11 months ago #

    Thanks-I realised that I had posted in a completely random section-sorry!

    I did both of those things which did not work and is why i ended up deleting the section.I have got the original version saved. I suppose i'll just have to find a way of manipulating it.

    Lauren

  4. Peter Booker
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Lauren,

    No problem at all. Sorry my input wasn't helpful then!

    If it was a custom theme, it might not have been made with compatibility for turning the comments on/off. In which case customising the files, or using a different theme are the answers.

    If you are just getting a blank white page it means that PHP has had an error but is not set to display errors. You may have an error log file somewhere, or be able to turn displaying errors on, which would help work out what is causing the problem.

  5. LaurenWilson
    Member
    Posted 11 months ago #

    Thanks Peter,

    It was indeed a custom theme. As I deleted the PHP entirely I fully expect that that is the issue. I'll put it back in and i'm sure that there will be some form of short code available somewhere. I will have a look in the error file too though to double check if this is the issue.

    Lauren

  6. Peter Booker
    Member
    Plugin Author

    Posted 11 months ago #

    Good luck getting it working as you want Lauren!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.