WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] posts not showing on main page (10 posts)

  1. mjmund
    Member
    Posted 2 years ago #

    i installed wordpress into root/blog and the mainpage/homepage/frontpage of the blog seemed to display ok. so i made a sample post and when i clicked on "view post" i got a 404 error. i checked the /blog folder and it had index.php and .htaccess but the root directory only had .htaccess so i copied (not moved) the index.php from the /blog into the root. now when i make a sample post, and click on "view post" it comes up just fine, however back on my main/home/front it does not show my new post or any posts. any suggestions? am i missing another file in the root ?

  2. Pothi
    Member
    Posted 2 years ago #

    Are you trying to give WordPress its own directory? If yes, did you follow all the steps?

  3. mjmund
    Member
    Posted 2 years ago #

    my web page is http://www.4ever2weeksandaday.com and my blog is in http://www.4ever2weeksandaday.com/blog
    i followed the info regarding the index.php and the .htaccess but left the permalinks "as is" because i was not sure how they should be set.
    i think now that maybe that was my problem - BUT, before your post, i had played with the .htaccess and index.php files and i think i messed them up. i re-copied the index.php from the /blog to the root - now nothing works.
    do i need to uninstall wordpress and then re-install ?
    if so, what files do i need to manually delete from the root? the un-install will take care of everything in the /blog folders.

  4. Vince Wicks
    Member
    Posted 2 years ago #

    I encountered this kind of issues.Until now I don't know how to find my post.It is being posted, but when it comes to viewing it, it's missing.Hopefully, we can resolve this problem.

  5. Pothi
    Member
    Posted 2 years ago #

    Currently, I only see an error message ("Directory has no index file") on your "blog".

    If you are going to keep your main web page and blog as separate entities, then there is no need to copy index.php, .htaccess or any other file to the root directory.

    now when i make a sample post, and click on "view post" it comes up just fine, however back on my main/home/front it does not show my new post or any posts.

    If you publish a post or page at "blog" (4ever2weeksandaday.com/blog), it won't show up on your site's root (4ever2weeksandaday.com).

    If you are trying to integrate both the main site and the "blog", then you can do it by removing whatever at the root directory and then installing WordPress at the root. Please be sure to take a backup of your main site, if you ever remove anything from your site.

    Please let us know, if you are unclear.

  6. mjmund
    Member
    Posted 2 years ago #

    ok, i un-installed and re-installed wordpress to clean up any files that i may have messed up.
    i tried again with wordpress loaded in 4ever2weeksandaday.com/blog
    same problem.
    under settings-general, i had the blog listed as 4ever2weeksandaday.com/blog
    and had the "site url" listed as 4ever2weeksandaday.com
    i added the /blog to the 'site url' and everything looks like it is working now

  7. mjmund
    Member
    Posted 2 years ago #

    yes, i intended to integrate a "main site" with a "blog tab" that would direct to the wordpress blog - - might have been able to acheive the same thing with a custom static front page, but being new to this, and being familiar with "old fashioned HTML" and not wanting to spend alot of money, i just made a simple "static web site" that i wanted to include a "blog" with it

  8. mjmund
    Member
    Posted 2 years ago #

    had to un-install and re-install to fix the index.php and .htaccess files but still had same problem.
    Under SETTINGS - GENERAL - i had wordpress location listed as ever2weeksandaday.com/blog and the "site URL" without the /blog
    FIXED problem by simply adding the /blog to the "site URL" under SETTINGS - GENERAL

  9. Pothi
    Member
    Posted 2 years ago #

    I'm glad you fixed it now. You may want to mark this thread as resolved when you get a chance.

  10. mjmund
    Member
    Posted 2 years ago #

    fixed

Topic Closed

This topic has been closed to new replies.

About this Topic