WordPress.org

Ready to get started?Download WordPress

Forums

IntelliWidget Per Page Featured Posts and Menus
[resolved] Posts in widget are shown thrice (6 posts)

  1. mnolte
    Member
    Posted 10 months ago #

    I wanted to use intelliwidget to publish posts that belong to a special category in the sidebar of my blog. My theme is "esplanade".

    There are six posts in this category, published in the last two years (I have moved the blog from another domain). Now I want intelliwidget to show this six posts with thumbnail and title in the sidebar, so I adjusted the widget accordingly. It works fine if I put only the four oldest articles in the respective category. The newest ones, however, are being shown thrice - don't know if it has got something to do with the date. When I put this two posts into another category, everything seems to be normal. This problem seems to occur in different categories, but not in all.

    All six posts are in the same category, each of them has an image, there's nothing special. I cannot see the difference between the two posts with the error and the other four.

    The blog adress: http://www.noltejournal.de/Magazin -> Sidebar.
    (I've adjustet intelliwidget to show 10 posts to visualize the issue.)

    Can anyone help?

    http://wordpress.org/extend/plugins/intelliwidget-per-page-featured-posts-and-menus/

  2. lilaeamedia
    Member
    Plugin Author

    Posted 10 months ago #

    Can you post a screen shot of the IW settings panel used to generate this? I have a suspicion about the cause.

  3. mnolte
    Member
    Posted 10 months ago #

    Hello lilaeamedia;

    thx for your response. Since I can't find a function to attach a pic to this post, I uploaded the screenshot here:
    http://www.noltejournal.de/Magazin/screenshotintelliwidget.jpg

    There is no entry in the Custom Text/HTML section.

  4. lilaeamedia
    Member
    Plugin Author

    Posted 10 months ago #

    This is being caused by an obscure issue the query class somehow. I cannot duplicate on my end, so would it be possible to get a temporary admin account to your wordpress? If so, you can send it to me on my website contact form: http://www.lilaeamedia.com/about/contact/

    I would like to put a debug comment in the script so I can see the raw data that is being returned. That will tell me where the query is duplicating the results.

  5. mnolte
    Member
    Posted 10 months ago #

    OK, then. You've got mail.

    Also, I've stumpled upon another Problem. I've put another intelliwidget in the sidebar which should list posts from another category. I haven't attached images to the posts, so it's no wonder that there are no thumbs - but the widgets only lists rather old posts, although here are a couple of newer posts in this category.

    Don't know if this has got something to do with the other Problem...?

  6. lilaeamedia
    Member
    Plugin Author

    Posted 10 months ago #

    Problem solved! I was not aware that featured images can have multiple rows of the same post_id, _thumbnail_id combination. I added GROUP BY across all the subqueries. It is working now on your site, I will push a patch to the WP repo later this PM.

    I believe your new problem was simply sorting by title ASC (default) instead of post_date DESC. I made the change for you.

    Danke for the heads up!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags