WordPress.org

Ready to get started?Download WordPress

Forums

Posts displaying but pages are not (2.3) (8 posts)

  1. cou
    Member
    Posted 6 years ago #

    Hi all,

    I've spent days trying to understand why this isn't working and haven't found any help in the forums. So hopefully I won't get shot down for asking this!

    Ever since upgrading to 2.3, I just cannot get Pages to work (site.com/mypage/). The site and the posts all work fine, but pages are blank.

    1) The title of the page is displayed in the <header>

    2) No errors are shown

    3) The page is blank. No content is shown, and it's not hidden in <!-- --> etc in the HTML. Have a look at this for example

    I've checked the theme, which looks fine to me. And I've tried other themes too - no joy. Here's the code for the page template:

    <div id="content">
    
    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>		
    
    		<h2 id="post-<?php the_ID(); ?>"><?php the_title(); ?></h2>
    		<div class="postspace2">
    	</div>	
    
    				<?php the_content('<p class="serif">Read the rest of this page &raquo;</p>'); ?>
    
    				<?php link_pages('<p><strong>Pages:</strong> ', '</p>', 'number'); ?>
    
    		<?php endwhile; endif; ?>
    	<?php edit_post_link('Edit this entry.', '<p>', '</p>'); ?>
    
    </div>

    In short...help!

    Any advice much appreciated.

    Will

  2. moshu
    Member
    Posted 6 years ago #

    For some odd reasons the amazon javascript on Pages has a different variant and bad code... check it.

  3. cou
    Member
    Posted 6 years ago #

    Good idea Moshu. I tried removing all Amazon's links...but still no joy. This is driving me insane!

  4. moshu
    Member
    Posted 6 years ago #

    That wasn't an "idea" - I saw the bad code there in your sidebar :)

    And NO, you did NOT remove it, just commented out...
    <SCRIPT charset="utf-8" type="text/javascript" src="http://ws.amazon.co.uk/widgets/q?ServiceVersion=20070822&MarketPlace=GB&ID=V20070822/GB/thecorridorof-21/8006/43b64346-a352-4509-a95b-7d7522b5993f"> </SCRIPT> <NOSCRIPT><A HREF="http://ws.amazon.co.uk/widgets/q?ServiceVersion=20070822&MarketPlace=GB&ID=V20070822%2FGB%2Fthecorridorof-21%2F8006%2F43b64346-a352-4509-a95b-7d7522b5993f&Operation=NoScript">Amazon.co.uk Widgets</A></NOSCRIPT>-->

  5. cou
    Member
    Posted 6 years ago #

    OK, smart alec - you got me! But I've now removed it and it's still not working. Any other ideas? (and this time I mean idea!)

  6. Roy
    Member
    Posted 6 years ago #

    Well, I just upgraded to 2.3.1 and my pages don't show either and it is just plain text, nothing fancy. It proves to be the theme, the default theme (which uses the same link) works just fine............................

  7. csleh
    Member
    Posted 6 years ago #

    Only an idea, but have you tried adjusting the css? I had a similar problem where if the content was floated left against the sidebar the page was blank. Float:right fixed it. Senseless really, since the float:left worked in previous wordpress version.

  8. cou
    Member
    Posted 6 years ago #

    I finally fixed it. It was a broken plugin - WPTags 4 Metakeywords. Basically, none of my pages were tagged which caused it to break.

Topic Closed

This topic has been closed to new replies.

About this Topic