WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Posts displayed in Wrong category archives (9 posts)

  1. marhgil
    Member
    Posted 3 years ago #

    Hello!

    In my installation, posts are displayed in Wrong categories. You can check sample here: http://www.batangastoday.com/news/technology/

    You'll see that the list is totally random. But some categories are ok. Like the Weird category: http://www.batangastoday.com/news/weird/

    Even inside the Dashboard, when I Filter the post by Categories, the results are the same, posts are showing on wrong categories.

    However, my Archives page that groups the post by Categories are ok:
    http://www.batangastoday.com/archives/

    Also, sub-categories are working fine.

    Example: Internet subcategory under Technology lists all the posts correctly.

    http://www.batangastoday.com/news/technology/internet/

    Is this a bug or something?

    I already tried reinstalling my WordPress via Dashboard, Reinstall Automatically to make sure I'm using the latest version. But still, posts are displayed on wrong categories.

    I also tried disabling plugins (I have the CaPa plugin) but still, same problem occurs.

    Can someone help me on this?

    Thanks,
    Marhgil

  2. Tara
    Member
    Posted 3 years ago #

    I also tried disabling plugins (I have the CaPa plugin) but still, same problem occurs.

    Is that the only plugin you have installed? If there more plugins, then try:

    -deactivating ALL plugins. If the problem goes away, activate them individually to find the culprit?

    -i fthat does not resolve the issue, try switching to the default theme (Twenty Ten) by renaming your current theme's folder in wp-content/themes to rule out any theme-specific issue?

  3. marhgil
    Member
    Posted 3 years ago #

    @t-p

    thanks for your suggestion. I did disable all the plugins and the problem persists. so, it's not the plugin.

    switching to default theme still shows wrong post in the category.

    It's not theme specific since even filtering by category at the dashboard shows wrong results.

    Here's the situation right now:

    Sub-categories are OK.
    Example:
    http://www.batangastoday.com/news/technology/internet/
    http://www.batangastoday.com/news/entertainment/music/
    http://www.batangastoday.com/news/sports/boxing/

    Main Categories with NO sub-categories are OK.
    Examples:
    http://www.batangastoday.com/news/opinion/
    http://www.batangastoday.com/news/weird/

    Main Categories with sub-categories are my problems, showing wrong posts not assigned to them:
    Example:
    http://www.batangastoday.com/news/technology/
    http://www.batangastoday.com/news/entertainment/
    http://www.batangastoday.com/news/sports/

    My WordPress installation is updated to 3.0.1 and I even reinstalled it to make sure I'm not using a hacked version.

    I'm thinking, it might be a problem to an internal MYSQL query. My database is already large with 1000+ posts, 5000+ tags, 12 main categories and 58 sub-categories.

    Any ideas, anyone?

  4. Tara
    Member
    Posted 3 years ago #

    I'm thinking, it might be a problem to an internal MYSQL query. My database is already large with 1000+ posts, 5000+ tags, 12 main categories and 58 sub-categories.

    you may try optimizing the database. there are many plugins:

  5. marhgil
    Member
    Posted 3 years ago #

    Hi t-p,

    Thanks for the suggestion. Although I'm already using WP-DBManager and even set it to optimize my database every 5 minutes.

    I also tried manual optimization by using Repair and Optimize commands thru PHPMyAdmin. Still problem persists. :(

    Is there a way to know the actual MySQL query passed by WordPress to MySQL when filtering the post by category on the Dashboard? That would really help my investigation, since I could run it manually against MySQL and see if it returns the correct result, or see what is wrong with the query.

    Marhgil

  6. marhgil
    Member
    Posted 3 years ago #

    Just an update.

    I installed WordPress on my PC and imported the database from batangastoday.com. Without the plugins and using the default theme, it shows the correct posts on categories. Even on the Dashboard filter.

    Then I tried installing the plugin one by one to see if they will alter the result. I've installed all the plugins and it's returning the correct results.

    Then I installed my theme. Again, no change. It displays the correct posts under the same plugin.

    I think, I should make a manual reinstall of WordPress 3.0.1. Maybe, the automatic reinstall did not replace all the files.

    I'll update this thread after the manual reinstall if it will fix my problem.

  7. marhgil
    Member
    Posted 3 years ago #

    I'm at a lost here. I even installed the latest 3.0.2 update. Still, the posts are showing on wrong categories. Any Suggestions?

  8. JRally
    Member
    Posted 3 years ago #

    I'm having the same issue and have tried all the little tricks listed in here too.

    Best example...in this category:
    http://www.warriorproducts.com/wpress/?cat=11

    The only article listed in this category is this one:
    http://www.warriorproducts.com/wpress/?p=60

    But you don't find that article until the third page.

    More or less it looks like it is showing all articles in all categories no matter what category it is set to be published in.

    EDIT - Found my issue. I was using a plugin to exclude pages/posts and it was causing the issue.

  9. marhgil
    Member
    Posted 3 years ago #

    Seems like this problem was resolved on WordPress 3.0.4. My categories are now OK after upgrading.

Topic Closed

This topic has been closed to new replies.

About this Topic