WordPress.org

Ready to get started?Download WordPress

Forums

Posts display backwards by date (oldest first) (11 posts)

  1. simpix
    Member
    Posted 2 years ago #

    I just upgraded to 3.3.1 and the posts on the home page are now not displaying properly. They seem to be ordering themselves backwards by date so that the oldest ones are displaying first. I don't see any way to change this on the reading settings page or any other settings.

    Also, I don't think the reading settings are working correctly anyway because when I change the number of posts to display or the summary vs. full, neither of those changes take effect.

  2. justingreerbbi
    Member
    Posted 2 years ago #

    ????? you may have to add some code in the loop to sort by date and ASC

  3. simpix
    Member
    Posted 2 years ago #

    The code in all the template pages was not changed so it should all be the same as it was before. The only thing different is that I upgraded the wordpress software to 3.3.1.

  4. justingreerbbi
    Member
    Posted 2 years ago #

    This is what I am saying.. I do not know for sure but maybe in the upgrade version WordPress changed it queries around a bit.. I don't know, I have not looked into it but this is why plugins and themes should be updated as well because things like this happen.

  5. simpix
    Member
    Posted 2 years ago #

    The theme and all the plugins are updated. I also deactivated all the plugins to see if that made a difference. Do you know where in the code that sorting method would be? index.php under Themes > Editor? I glanced through that code and don't see anything that is standing out, but there is a LOT of code in there. :)

  6. simpix
    Member
    Posted 2 years ago #

    Can you give me a code segment and tell me where to put it that would tell the index.php page to sort posts by date? That's the only page that isn't working correctly.

  7. simpix
    Member
    Posted 2 years ago #

    It appears to be sorting by post ID and not date because when I change the post date, it doesn't change the display order. The template is London Creative.

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  9. simpix
    Member
    Posted 2 years ago #

    I did try deactivating all the plugins and that made no difference.
    When I changed it to Twenty Eleven, it displayed correctly, so it does seem to be theme-specific.

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    As London Creative is a commercial theme, you need take this up with the theme's vendors.
    http://themeforest.net/forums/topic/themeforest/themeforest

  11. simpix
    Member
    Posted 2 years ago #

    OK, thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic