WordPress.org

Ready to get started?Download WordPress

Forums

post.php open dialog pops up when saving posts (6 posts)

  1. SouthBeach030
    Member
    Posted 6 years ago #

    I have a relatively simple problem.. I tried searching the forum to no avail.

    Lately, and only during PEAK time on my server, I get a dialog box that pops up asking me to open post.php whenever I save, edit or publish a new or previous post.

    This only happens during peak usage during the day. I can edit and manage my site fine off-hours.

    Can anyone help me determine what might be causing this?

    Is it a MySQL issue, and the my.conf file needs editing? Or is it an Apache issue, and I need more connections in the httpd.conf file?

    I checked all my plugins, and they're accurate. I don't get spam, and disabled trackbacks long ago.

    A couple things to note are:

    - I'm using PHP_Speedy, and have the latest version
    - I used to run an HTTP reverse proxy called Varnish, but removed it a month or so ago.

    My guess is that it has something to do with a capacity setting that I could tweak.. since it only happens when the server is busy.

    I get about a million pageviews monthly.
    Dedicated server, 2gb ram, etc.

    Any suggestions?

  2. SouthBeach030
    Member
    Posted 6 years ago #

    It's now happening during off-peak times as well.

    I discovered it might have been some issues with the setting in php.ini, but that didn't help.

    Any suggestions or leads?

  3. Chris_K
    Member
    Posted 6 years ago #

    Have you checked your web server's error logs yet?

    Anything logged about PHP running out of memory?

  4. SouthBeach030
    Member
    Posted 6 years ago #

    No memory issues. I tinkered around with php.ini, and it had been set to have a sufficient amount of RAM.

    I thought it might have been the "max_execution_time" as it was set to 30 seconds, and a "save" post took about 20 seconds. So I raised it to 60 seconds.

    I also suspect it might be the Google Sitemaps plugin..

    But in regards to PHP "running out of memory," is that specific to the "memory_limit" function? Or is that memory_limit just per process?

    I had originally had it at 192M, then increased to 224M.. but thought that was way too high, and lowered it to 64M yesterday.

    If I need to increase it, I can...

    What is the usual culprit for the post.php box popping up?

    What other server configuration settings should I be on the look out for?

    Lastly, I can't find my server logs.. any suggestions of where it'd be?

  5. SouthBeach030
    Member
    Posted 6 years ago #

    PS, Since it can take over 20 seconds to save a post, I also changed my httpd.conf file "Timeout" from 20 to 45 seconds, since it was too coincidental...

  6. SouthBeach030
    Member
    Posted 6 years ago #

    I solved the problem, for those interested.

    I was getting this error:
    PHP Fatal error: Allowed memory size of 16 bytes exhausted (tried to allocate 32 bytes) in /home/<dir>/public_html/<blog name>/wp-content/plugins/google-sitemap-generator/sitemap.php on line 1790
    Allowed memory size of 16 bytes exhausted (tried to allocate 228 bytes)

    I was using beta version 3.0b7 of Google Sitemaps.

    I upgraded to the latest stable 3.0.3, and everything works perfectly. It builds the site map in the background, and has improved memory performance.

    FYI, those should note that even though it say use on WP 2.1+, it actually works on 2.0.11

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.