WordPress.org

Ready to get started?Download WordPress

Forums

Post,permalink (14 posts)

  1. brook1979
    Member
    Posted 2 years ago #

    Hi people,

    This is really frustrating me now. im trying to implement a blog on a friends site that was already set up as static pages, i managed to get the page into place but when you click on a post title, or in a "latestpost widget" it redirects to the home page. heres the link
    http://www.good4rentals.com/latest-news

    Please could someone point me in the right direction??

    Cheers in advance.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try resetting your custom permalinks back to the default setting. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  3. brook1979
    Member
    Posted 2 years ago #

    Hi Esmi,

    Thanks for the reply. much appreciated.

    I set them back to default but without success....I do kind of understand wordpress etc, but im stumped, ive tried a few things, made sure codes are there that are suppose to be etc and still in square 1.

    Any ideas??

    Cheers again for the help.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Your post title links are working for me now.

  5. brook1979
    Member
    Posted 2 years ago #

    Really??....i just changed the structure to the following,
    /%year%/%postname%/

    So it definately worked?? it took you to the actual post page??

    Dont take my above questions the wrong way, im just still confused...lol.

    thanks again for the assistance.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    It really worked. Clicked on the title of the first post and it took me straight to that single post's page.

  7. brook1979
    Member
    Posted 2 years ago #

    right ok...sorry im getting confused, its not working for me.... ok i now have the structure set at /%year%/%postname%/

    could you try it now and let me know if this is working, because this isnt working for me...cleared browser cache etc still nothing,...just keeps re-directing me to the homepage.

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Hmm - now it's broken again. Can you try resetting your custom permalinks back to the default setting and deleting the .htaccess file in your WordPress root folder?

  9. brook1979
    Member
    Posted 2 years ago #

    ok now it is set at
    /

    which is what it was when you said it was working

  10. brook1979
    Member
    Posted 2 years ago #

    this just reverts back to home page....
    so not this one.....

  11. brook1979
    Member
    Posted 2 years ago #

    ok now it is set to default, and deleted .htaccess

  12. brook1979
    Member
    Posted 2 years ago #

    the page id is 594...

    i just tried and nothing....still re-directing back to home page..
    :(

  13. brook1979
    Member
    Posted 2 years ago #

    this is my code from my child theme "single.php" I dont think there is anything missing....esmi have you give up on me lol..

    ANYONE!!

    [Code moderated as per the Forum Rules. Please use the pastebin]

  14. esmi
    Forum Moderator
    Posted 2 years ago #

    esmi have you give up on me

    Please try to be patient. Even forum volunteers have to eat, sleep etc.

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic