WordPress.org

Ready to get started?Download WordPress

Forums

Post/Page HTML editor bar icons missing in WP 3.3 (7 posts)

  1. y2kemo
    Member
    Posted 2 years ago #

    There used to be menus and buttons in my site's HTML post/page editor bar. These are no longer available in WP3.3. Is this a plugin issue? Did something change in how plugin authors need to add items to the editor menu? Any help would be appreciated.

  2. Make sure you've read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install's about page - http://domain.com/wp-admin/about.php - to see what's new.

    And then make sure you've tried...

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    - switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can't log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    - manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

  3. y2kemo
    Member
    Posted 2 years ago #

    Could not find the issue on the master list.
    Cache flushed (site and all browsers on 3 machines)
    deactivated plugins
    reset plugin folder
    changed themes
    manually upgraded (btw, widget saving feature works great)

    Still, the plugin-specific post editor menu item is missing. When I downgraded to 3.2 the menu item reappeared.

  4. Shyzer
    Member
    Posted 2 years ago #

    y2kemo, any chance you're running the WPtouch Pro and WordPress SEO plugins?

  5. y2kemo
    Member
    Posted 2 years ago #

    I am. But disabling them did nothing to fix the issue.

  6. Shyzer
    Member
    Posted 2 years ago #

    Hmm, I found that when both plugins were active in WP3.3, the post-editor vanished. I thought that might have been the same issue for you as well.

  7. y2kemo
    Member
    Posted 2 years ago #

    I still have the post editor. I'm just missing the add-on menus/items that plugins add.

Topic Closed

This topic has been closed to new replies.

About this Topic