WordPress.org

Ready to get started?Download WordPress

Forums

/%postname%/ permalinks setting not working properly (11 posts)

  1. Capefox
    Member
    Posted 2 years ago #

    I have set my Permalinks structure to /%postname%/ and saved the changes but I still get /category/ appearing between my domain name and the post name, e.g.: "mydomain.com/category/postname. Even after I refresh the page the word "category" remains.

    I was advised to delete the "htaccess" file so I deleted it but it made no difference.

    How can I stop the word "category" from appearing in my permalinks?

  2. cristopher_elsner
    Member
    Posted 2 years ago #

    hello,

    If you use this "/%postname%". may be it solve.
    just remove one backslash behind from above code.

    Crish.

  3. Capefox
    Member
    Posted 2 years ago #

    Thanks, Crish - but it did not work, unfortunately. It's a very stubborn problem! I've sent a message to my hosting company, I hope they can help. Best wishes!

  4. cristopher_elsner
    Member
    Posted 2 years ago #

    hi,

    If you set your htaccess file with this code may be it will be set as per your requirement.

    Code :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Thanks.
    crish

  5. Capefox
    Member
    Posted 2 years ago #

    Thank you, Crish! I managed to sort out the problem and am happy with the result. Best regards!

  6. mauricen
    Member
    Posted 1 year ago #

    Capefox... I am having the same issue... how did you fix this? My .htaccess file matches this - doesn't work. Every time I set permalinks to "Custom Structure" and click SAVE, it resets it to "Post name", the option above.

  7. Capefox
    Member
    Posted 1 year ago #

    mauricen, I am sorry but I have no recollection of how I fixed this problem - it was 6 months ago! I hope someone else can help you. Best regards!

  8. k1ypp
    Member
    Posted 1 year ago #

    We're seeing the same problem as mauricen (above). The "save" resets back.

    "Every time I set permalinks to "Custom Structure" and click SAVE, it resets it to "Post name", the option above"

  9. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Please list your domain, your post slug, and your post id for our testing.

  10. k1ypp
    Member
    Posted 1 year ago #

    The domain: http://janevblanchard.com/

    There is no particular post. We're in the dashboard, dealing with the Permalink choices. See the screenshot:

    Whenever we click the "Custom structure" choice and hit save, it jumps back to "Post name."

  11. lk.wasa
    Member
    Posted 1 year ago #

    I got the same problem, (in Xampp/Localhost)
    & it had something to do with mod_rewrite is not enabled

    This post help me to reslove that!
    http://www.leonardaustin.com/technical/enable-mod_rewrite-in-xampp

Topic Closed

This topic has been closed to new replies.

About this Topic