WordPress.org

Ready to get started?Download WordPress

Forums

posting via e-mail -- POP3 quit: connection does not exist (22 posts)

  1. JoshRoseman
    Member
    Posted 5 years ago #

    Greetings. I'm on my third version of WP (2.6.3, 2.6.5, and now 2.7), and post via e-mail still does not work. Here is the error I receive when I run wp-mail.php:

    POP3 quit: connection does not exist

    I have put in the e-mail address and password, and gotten the server and port info from GoDaddy. I have also tried this with my company's webmail server, but to no avail. Same error.

    How can I make post-by-email work? My boss would really like it to work.

    Site: 11aliveblogs.com

    Thank you.

  2. skiboyjon
    Member
    Posted 5 years ago #

    I'm having the exact same problem. All my e-mail settings are correct, the e-mail is working, but wp-mail.php pops up with that error. This is a major part of the site i'm working on, the owners need easy access for updates.

    Anyone have suggestions out there on how to troubleshoot this?

  3. mjpratt
    Member
    Posted 5 years ago #

    I was having the same problems until I changed my email password.

  4. JoshRoseman
    Member
    Posted 5 years ago #

    mjpratt, that is not the problem I've been having. All my passwords are triple-checked.

  5. markusvo
    Member
    Posted 5 years ago #

    I'm also at goDaddy (shared server). I have debugged the problem up to the point where the fsockopen in class-pop3.php times out without establishing a connection to goDaddy's POP server.

    After three emails to the goDaddy support desk, the best answer I could get from them is:

    Unfortunately we do not allow outgoing connections through port 110 from our shared hosting environment.

    Please post a reply here if you could convince goDaddy to change their policy.

  6. markusvo
    Member
    Posted 5 years ago #

    I did another test from goDaddy's shared hosting, this time using a POP account at my ISP i.e. not my goDaddy POP account. The posting by email to WordPress works smoothly!

    The problem therefore seems to be at the goDaddy's POP server not receiving incoming connections from their own (and maybe other) hosts.

  7. ccaillouet
    Member
    Posted 5 years ago #

    I have a similar problem and i have tried three different mail servers, one on the same ISP and two on different servers, with no joy. When i call .../wp-mail.php, I get the same message after a timeout:
    POP3 quit: connection does not exist

    I am obviously getting to the POP request because it fails with the specific error.

    I also tried forcing the server, user and password in "class-pop.php", with the same result, so it seems to be something external to WordPress, but the cause is still a mystery. It could be related to the host server and port 110 outgoing access but the ISP claims that it should work.

    It looks like i am out of tricks for email posting, at least for now. Thanks for the ideas.

    crc

  8. endlessmonkeys
    Member
    Posted 5 years ago #

    I'm getting this problem as well. I host at GoDaddy, but the account is a GMail account. Looking at the above info, it looks like it might be a GoDaddy problem? Seems odd, but it would make sense. Thought I'd give this topic a bump and see if the account being a GMail account made any difference, although I'm assuming it doesn't.

  9. cmleung
    Member
    Posted 5 years ago #

    Anyone figure out the problem? I host at netfirms, tried to use yahoo account, my ISP, another hosting account, nothing works.

  10. troppmann
    Member
    Posted 5 years ago #

    has anyone seen this issues on dreamhost mail servers? getting the same thing and having a headache getting it working....

    anyone? thanx...

  11. DavidMjps
    Member
    Posted 5 years ago #

    Add me to the list of people having the same problem. I'm hosting with Godaddy and receiving the:
    'POP3 quit: connection does not exist'
    message when I run ../wp-mail.php

  12. valerama
    Member
    Posted 5 years ago #

    Ditto here. I even set the port number to that recommended by my host. I guess I can check with the hosting company (LunarPages).

  13. bantrycsa
    Member
    Posted 5 years ago #

    Another ditto.

    Is there any way it could be done by using localhost for the mail address?
    If the mail host is on the same server?

    Ron

  14. bantrycsa
    Member
    Posted 5 years ago #

    Update.

    Changed the password to something simple, instead of containing underscores and stuff, and it works.

  15. tmargot
    Member
    Posted 5 years ago #

    I had this very problem and searched everywhere for an answer with no success. It may seem obvious to most but I was certain of my settings. I finally figured it out, my POP3 port is 110 and not 25.

  16. William
    Member
    Posted 5 years ago #

    I am utilizing Yahoo! Webhosting... after lengthy search on Yahoo! technical side, it was determined that problem was in the fact that I could not access mail processes on the mail server.. my webspace is on separate server from mail processes.

    I do not see the logic in that response. WordPress is acting like email client when it is trying to hit the pop3 server for mail. what am I missing here???? anyone else have experience with this problem while using Yahoo! Webhosting?

  17. JT101
    Member
    Posted 5 years ago #

    I'm also using Yahoo! small business webhosting. Still haven't found a solution yet myself. THe only likely one to me could be the password thing?

  18. JT101
    Member
    Posted 5 years ago #

    Hi again

    Ok, I've tried virtually everything. I have WordPress 2.7.1. Just spent an hour on the phone with Yahoo Small Business tech.
    the error I'm also getting is: POP3 quit: connection does not exist

    These are the best links out there:
    http://codex.wordpress.org/Blog_by_Email
    http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/wordpress/wordpress-34.html

    Yahoo really gives the impression that they support WordPress, and yet this forum shows they don't.

    Cron seems to be out of date. Possibly not compatible with 2.7.1, but in anycase, it didn't work.

    Tried Automated Browser Activation suggestion but didn't work

    the most promising look like Postie and the .qmail sggestion, but I don't know what .qmail is. I am forwarding all my business e-mails to my personal account, don't know if qmail has something to do with it.

    Cheers

  19. Kevin S
    Member
    Posted 5 years ago #

    hi,

    I was having same problem. There is nothing wrong with WordPress scripts. Its all with your localhost.

    Its all due to MXentry setting problem in your website c-panel.

    Please visit: http://annanta.com/web-world/wordpress-not-sending-email-try-this-fix/ For complete solution.

  20. ECCESSO
    Member
    Posted 4 years ago #

    HI!I am very new to the WP-blog society using the 2.8.4 ver. I also register some problems with the POSTIE PLUG by adressing my Gmail.com account. I have changed all the paramenters, in both the pop and imap features, and keep receiving the error message from the manual script test:Checking for mail manually

    This is the postie plugin
    Revision: 149093
    Last Changed Date: 2009-08-25 17:48:05 -0400 (Tue, 25 Aug 2009)

    Connecting to imap.gmail.com:143 (imap)
    Mail Connection Time Out

    Common Reasons:

    Server Down

    Network Issue

    Port/Protocol MisMatch

    The Server said:Connection failed to gmail-imap.l.google.com,143: Connection timed out

    A similar error message is received in the config test.
    Since this issue is more then 12 months old, and never has been solved, why don´t you avoid using the POSTIE plug, because I don´t think it ever will work regarding to the features users find in the description of the plug.
    Rgs Andy

  21. rqbanerjee
    Member
    Posted 4 years ago #

    I was having the same problem. Do you have a Linux VPS or shell access to the machine?

    I had the same error, POP3 quit.....

    and noticed this in /var/log/messages :

    Sep 10 13:20:03 hindoogle xinetd[22171]: START: pop3 pid=28119 from=216.xxxxx
    Sep 10 13:20:05 hindoogle popa3d[28119]: Authentication failed for xxxx from 216.xxxxx
    Sep 10 13:20:05 hindoogle xinetd[22171]: EXIT: pop3 status=0 pid=28119 duration=2(sec)

    so.... the password was wrong. I wish WordPress gave a better error message.

  22. Travis Designs
    Member
    Posted 4 years ago #

    Regarding "POP3 quit: connection does not exist"

    My hosting co (lonex) has an option in the cPanel "Outgoing Connections Manager" You can use this (if you have it) to specify the IP address of the request and allow it. Mine even shows blocked connections (which were WP failed attempts to get mail). Specify the IP address & if available & at your own risk "allow port 25" this is the SMTP. Hope this helped...somebody!

Topic Closed

This topic has been closed to new replies.

About this Topic